Leaking? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 02-03-2013, 05:44 AM Thread Starter
jbarrett18
Registered User
2004 WJ 
 
Join Date: Feb 2013
Location: Oklahoma City
Posts: 6
Leaking?

Hi everybody...need a little help. Got under my jeep today to start replacing my transmission speed sensors, and this is what I see. Thoughts? Could it just be a seal?

image-3638395566.jpg



image-1992682482.jpg


2004 Jeep Grand Cherokee SE
4.7L Full Time AWD
Full Time Kid Hauler
Part Time Hunter
jbarrett18 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-03-2013, 09:54 AM
jokerchief462
Registered User
1989 YJ Wrangler 
 
Join Date: Nov 2010
Location: Sin City
Posts: 2,881
That is all it is just the output seal. Easy to fix and you may want to pick up a seal puller at NAPA $8. Its a great tool to have.

89YJ 2.5L TBI, AX-5, NP231 SYE, Ford 8.8, Yukon Grizzly, Tom Woods Shaft, 33" BFG T/As, 4" lift, Warn VR10000s.

AF Jeep Club Tail #184
jokerchief462 is offline  
post #3 of 6 Old 02-03-2013, 10:18 AM Thread Starter
jbarrett18
Registered User
2004 WJ 
 
Join Date: Feb 2013
Location: Oklahoma City
Posts: 6
You're right. Already got the seal, drive shaft removed. BUT, they gave me the wrong size...doh. After removing the old seal, I noticed a gouge inside that housing. Looks like someone has done this previously and wasn't very careful. Have the wife pick up the correct seal. Thanks!

2004 Jeep Grand Cherokee SE
4.7L Full Time AWD
Full Time Kid Hauler
Part Time Hunter
jbarrett18 is offline  
post #4 of 6 Old 02-03-2013, 10:19 AM Thread Starter
jbarrett18
Registered User
2004 WJ 
 
Join Date: Feb 2013
Location: Oklahoma City
Posts: 6
Here's what I see
Attached Thumbnails
image-83091191.jpg   image-1277658195.jpg  

2004 Jeep Grand Cherokee SE
4.7L Full Time AWD
Full Time Kid Hauler
Part Time Hunter
jbarrett18 is offline  
post #5 of 6 Old 02-04-2013, 01:45 AM
seattle_yj
Registered User
1993 YJ Wrangler 
 
Join Date: Jun 2012
Location: Issaquah
Posts: 946
Is that ding on the left on the seal? Yank that old seal, carefully, Put red rtv on the outside of the new seal before you seat it. Use a chunk of PVC to hammer it back on. Should fix your issue.
seattle_yj is offline  
post #6 of 6 Old 02-04-2013, 06:05 AM Thread Starter
jbarrett18
Registered User
2004 WJ 
 
Join Date: Feb 2013
Location: Oklahoma City
Posts: 6
Looks like its part of the housing.

2004 Jeep Grand Cherokee SE
4.7L Full Time AWD
Full Time Kid Hauler
Part Time Hunter
jbarrett18 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome