Idling/RPM issue 97 TJ Sport -

LinkBack Thread Tools
post #1 of 2 Old 06-19-2014, 10:21 AM Thread Starter
Registered User
Join Date: Aug 2013
Location: Levittown
Posts: 69
Idling/RPM issue 97 TJ Sport

I have a 1997 Jeep Wrangler Sport 6Cyl 4.0L. This past Saturday I pu the clutch in in 2nd gear and it stalled, but then started back up without a problem. But since then it has stalled 6 times. But many times when I put the clutch in, the RPMs just drop really low, like 100-200, and doesn't stall then the RPMs go back up on their own to about 800-900 within 10 seconds. I replaced the plugs, wires, and distributor cap today because the #1 cylinder was misfiring, different problem I hope. But the tune up corrected the misfiring. If anyone has any idea what the RPM issue could be, all help would be appreciated.

asnyder is offline  
Sponsored Links
post #2 of 2 Old 06-19-2014, 07:37 PM
Registered User
1990 YJ Wrangler 
Join Date: Mar 2010
Location: Lititz
Posts: 413
If the CEL isn't on Try cleaning your idle air motor and throttle body and see if there is a change.

BDS - Spartan - AtoZ Fabrication - Borgeson HD - USA Standard - BFGoodrich
Schaef81 is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome