i need help 4.0 problem - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 05-23-2012, 12:05 PM Thread Starter
funnyduck84
Registered User
1999 TJ Wrangler 
 
Join Date: May 2012
Location: toledo
Posts: 26
i need help 4.0 problem

i have a 99 tj with the 4.0 i just rebuilt the engine bord out 30 over and put a mild howerds cam in. but now it dosnt want to start and if i get it to start it runs rough and the timing is at 30 degrees. i dont know if its a timing or a fuel problem everything is stock except the cam. is there anything i need to change. i dont realy want to put the stock cam back it because i will be thowing at least 500 bucks down the drain.

funnyduck84 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-25-2012, 02:25 PM
MoparXJ
Registered User
1993 XJ Cherokee 
 
Join Date: Mar 2012
Location: El Paso
Posts: 44
Everything should work with aftermarket parts. Do basic and mild tests on your fuel lines for pressure and plugs for spark. Start off with putting your timing back at zero and made sure it's sparking on compression stroke. I'd I had to guess it's a timing issue.
MoparXJ is offline  
post #3 of 6 Old 05-25-2012, 02:51 PM
rjbruzan
Moderator
2004 TJ Wrangler 
 
Join Date: May 2008
Location: Lake in the Hills
Posts: 2,582
Distributer in wrong?
rjbruzan is offline  
post #4 of 6 Old 05-25-2012, 06:55 PM Thread Starter
funnyduck84
Registered User
1999 TJ Wrangler 
 
Join Date: May 2012
Location: toledo
Posts: 26
Ya I got it working I had to cut the tabs off the distributor to make it work
funnyduck84 is offline  
post #5 of 6 Old 05-25-2012, 07:09 PM
Mean Max
Don't poke the bear
 
Mean Max's Avatar
1991 YJ Wrangler 
 
Join Date: Jul 2007
Location: Stuart, Florida
Posts: 13,734
Quote:
Originally Posted by funnyduck84
Ya I got it working I had to cut the tabs off the distributor to make it work
Instead of just moving the distributor gear a tooth?

Max

Click here to see all of my different albums on Photobucket.
Choose any album to see all of my pics!


Quote:
Originally Posted by UltimatE View Post
Max has a picture of every Jeep part ever made.
Quote:
Originally Posted by Benderff View Post
No one here knows what they are talking about. You should try Pirate 4x4 they will be happy to help you.

There is no situation that cannot be improved with a small but well-placed explosive.
Mean Max is offline  
post #6 of 6 Old 05-25-2012, 09:17 PM Thread Starter
funnyduck84
Registered User
1999 TJ Wrangler 
 
Join Date: May 2012
Location: toledo
Posts: 26
Ya I tried one tooth but it was too much
funnyduck84 is offline  
Reply

Tags
4.0 , engine , rebuild , tj , wrangler

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Amp + Sub problem.. Help! dvdflanders Audio, CB & Ham Radios, GPS, & Electrical 11 12-10-2010 10:06 AM
Sub problem LiBMXr1390 Audio, CB & Ham Radios, GPS, & Electrical 7 03-26-2008 08:28 PM
More on my CB problem.. XabuJr Audio, CB & Ham Radios, GPS, & Electrical 10 08-03-2007 01:29 PM
Sub Problem Thump85 Audio, CB & Ham Radios, GPS, & Electrical 3 07-16-2006 03:46 AM
Problem in 4 low 1966cj5 Tires & Wheels 1 03-30-2006 05:25 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome