high idle - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 01-05-2014, 05:21 PM Thread Starter
launchpad51
Registered User
2005 WK 
 
Join Date: Jan 2014
Location: 100 mile house
Posts: 7
high idle

Hey Guys;
We just got a 2005 jeep grand cherokee laredo,4.7L 4x4.Yesterday it stated to idle high,like 1200 rpm.Not good,not cheap,as it will use more fuel.I read here about changing the TPS unit to correct this.I changed it and it is still doing the same thing.Someone mentioned that if you change that unit also change the other thats below and right of throttle body.Has anyone heard if that it should be replaced also.I want to get it running so that I can sell it and buy a new one.I get the feeling that this thing is going to nickel and dime me.There is 161,000 miles on it. Thanks in advance

launchpad51 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-10-2014, 11:09 AM Thread Starter
launchpad51
Registered User
2005 WK 
 
Join Date: Jan 2014
Location: 100 mile house
Posts: 7
Well that problem solved.A piece of the broken O2 senser plastic was stuck in the throttle plate.Once removed walla,good to go.
launchpad51 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome