High Idle - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > High Idle

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineGrizzly Lockers available at Rockridge4wd.comThe ULTIMATE "Selectable" Locker System! Brough

Reply
Unread 01-28-2002, 10:54 AM   #1
Mwrangler29
Registered User
 
Join Date: Jan 2002
Location: Milpitas, Ca.
Posts: 41
High Idle

Hey all:
I just joined the jeep community and I'm excited to be within it! I could almost say too excited.
I took my 97' Wrangler sport to a creek and tried to cross. Sure enough I got stuck and had to get pulled out.
After realizing that my whole engine compartment got caked with mud, I hosed it down after disconnecting the battery. Now she's idleing @ 1100 in neutral. Any idea what my problem is? I changed the plugs, cap and rotor, and air filter. Reset the computer as well.

Also, after raining hard, I pulled out of the driveway and as I pulled forward, water would pour out from under the dash board. Anyone know what that could be?

All your input is greatly appreciated!
Thanks,
Chris

__________________
97' Wrangler
4.0L
Borla Headers
Soft top
Top 5 sports rack
Bestop Seat covers
31x10.50 Dunlop Mudders
Mwrangler29 is offline   Reply With Quote Quick reply to this message
Unread 02-03-2002, 11:07 PM   #2
jeepdaddy2000
Registered User
1971 CJ5 
 
Join Date: Jan 2002
Location: Eagle Point Oregon
Posts: 6,237
Idling too fast,check your vacume lines. As for the water under the dash, check the heater box drain or the seal around the vent.
jeepdaddy2000 is offline   Reply With Quote Quick reply to this message
Unread 02-11-2002, 07:00 PM   #3
nengxj
Registered User
 
Join Date: Feb 2002
Posts: 22
Cleaning thorttle body
there are 3 sensors , idel , MAP
some mud may struck it
good luck
__________________
XJ 96 , 2.5 L
BF /MT/30X9.5 , WARN winch 8000 lbs. TJM bull bar
3 inch. lift custom made .
nengxj is offline   Reply With Quote Quick reply to this message
Unread 02-19-2002, 06:25 PM   #4
Mwrangler29
Registered User
 
Join Date: Jan 2002
Location: Milpitas, Ca.
Posts: 41
Well, I ended up having to take it to the dealer because none of my friends' computers would read the problem. Ended up being the MAP and IAC. The dealer was trying to charge me $400+ to replace it! All taken care of now. Did it my self for $80 (parts).
Thanks for the input.
__________________
97' Wrangler
4.0L
Borla Headers
Soft top
Top 5 sports rack
Bestop Seat covers
31x10.50 Dunlop Mudders
Mwrangler29 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.