hesitation and idle issue. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > hesitation and idle issue.

TeraFlex Now at Rockridge 4WD! BEST DEALS around!Alloy usa heavy duty ball joint kitsENGO QUADLUX 6" to 54" LED AMBER AND WHITE MULTI

Reply
Unread 10-30-2012, 07:47 PM   #1
Timrex
Registered User
1998 TJ Wrangler 
 
Join Date: Mar 2012
Location: Walpole, New Hampshire
Posts: 14
hesitation and idle issue.

Hello jf, I know this has been discussed before, but I haven't found many final answers to this issue. The jeep is a 98 wrangler 4.0 liter This problem happens when the jeep is hot or cold. The jeep takes three or more attempts cranking for it to start, which I will assume is the fuel pressure check valve. Then at around 2000 rpms it hesitates, backfires, and loses rpms unless I push in the clutch and give it enough gas to hit 3000 rpms. Then it will be fine for a second, then repeat over and over through every gear until I stop, at which point the idle drops down to 500 rpms or less, sometimes stalling. There is a strong smell of unburnt fuel in the exhaust, and it backfires on a downshift. Now to what I have done, replaced the downstream oxygen sensor after code p0138 was thrown, fuel injectors cleaned, IAC cleaned, TPS cleaned, TB cleaned. My last couple of suspicions are CPS and fuel pump. I haven't checked fuel rail pressure as I do jot have a fuel pressure gauge. I am stumped, not sure what I should do next.

Timrex is offline   Reply With Quote Quick reply to this message
Unread 10-31-2012, 11:10 AM   #2
Timrex
Registered User
1998 TJ Wrangler 
 
Join Date: Mar 2012
Location: Walpole, New Hampshire
Posts: 14
Bump, any help would be appreciated!
Timrex is offline   Reply With Quote Quick reply to this message
Unread 10-31-2012, 01:43 PM   #3
apnelson91
Registered User
1994 XJ Cherokee 
 
Join Date: Oct 2012
Location: marion, indiana
Posts: 5
check out my thread i have the same problem?!?!
apnelson91 is offline   Reply With Quote Quick reply to this message
Unread 10-31-2012, 04:54 PM   #4
Timrex
Registered User
1998 TJ Wrangler 
 
Join Date: Mar 2012
Location: Walpole, New Hampshire
Posts: 14
hmmm, i see that, very similar.
Timrex is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.