HELP! 98 5.9 wont stay running - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > HELP! 98 5.9 wont stay running

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineRuffstuff Axle Simple Swap Kit!ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO

Reply
Unread 11-23-2013, 07:54 PM   #1
hoodlum333
Registered User
 
Join Date: Nov 2011
Posts: 4
HELP! 98 5.9 wont stay running

Strangest thing happened today. I have a 98 Grand Cherokee 5.9 with about 175k. I have only owned it for about 6 months. So, I started it for the first time in several weeks and it immediately died. Starts just fine but I have to keep my foot on the gas to keep it running. It doesnt "sputter" out....it immediately drops to 0rpms once I take my foot off the pedal. The wierd this is that all settings reset (i.e. Radio) as if the battery died. Also, the gauge cluster lights dimmed in and out as I held it at about 2000 rpms. I did not drive it....just locked her back up and went inside. Any ideas? Thanks.

hoodlum333 is offline   Reply With Quote Quick reply to this message
Unread 11-24-2013, 07:38 AM   #2
copmedic309
Registered User
1995 XJ Cherokee 
 
Join Date: Sep 2013
Location: Woodbury, NJ
Posts: 65
Sounds like the CPS to me. I had similar symptoms. Replaced mine and no issues
__________________
Ry.
Rather be tried by 12, than carried by 6.
copmedic309 is offline   Reply With Quote Quick reply to this message
Unread 11-24-2013, 08:11 AM   #3
hoodlum333
Registered User
 
Join Date: Nov 2011
Posts: 4
Forgive my ignorance. CPS?
hoodlum333 is offline   Reply With Quote Quick reply to this message
Unread 11-24-2013, 08:13 AM   #4
copmedic309
Registered User
1995 XJ Cherokee 
 
Join Date: Sep 2013
Location: Woodbury, NJ
Posts: 65
Lol sorry, crankshaft position sensor. Notorious on Cherokees for going bad.
__________________
Ry.
Rather be tried by 12, than carried by 6.
copmedic309 is offline   Reply With Quote Quick reply to this message
Unread 11-24-2013, 08:14 AM   #5
copmedic309
Registered User
1995 XJ Cherokee 
 
Join Date: Sep 2013
Location: Woodbury, NJ
Posts: 65
And it won't throw a trouble code or engine light if it's bad.
__________________
Ry.
Rather be tried by 12, than carried by 6.
copmedic309 is offline   Reply With Quote Quick reply to this message
Unread 11-24-2013, 02:03 PM   #6
doghouse8632
Registered User
 
Join Date: Nov 2013
Posts: 19
Also look 4 a major vacuum leak or a malfunctioning idle air control valve...
doghouse8632 is offline   Reply With Quote Quick reply to this message
Unread 11-24-2013, 03:11 PM   #7
hoodlum333
Registered User
 
Join Date: Nov 2011
Posts: 4
Well....was gonna drive it to the auto store to test the battery and now it wont start. Click click click. Gonna pull the battery and have it tested.
hoodlum333 is offline   Reply With Quote Quick reply to this message
Unread 11-24-2013, 03:20 PM   #8
copmedic309
Registered User
1995 XJ Cherokee 
 
Join Date: Sep 2013
Location: Woodbury, NJ
Posts: 65
Did you hit the starter?
__________________
Ry.
Rather be tried by 12, than carried by 6.
copmedic309 is offline   Reply With Quote Quick reply to this message
Unread 11-24-2013, 04:03 PM   #9
hoodlum333
Registered User
 
Join Date: Nov 2011
Posts: 4
Just replaced the starter last month. Been reading other forums and many are suggesting that this may be an indicator of a bad (or going bad) battery.....amongst a plethora of other ideas. I dunno. Not my daily driver at the moment so I will pull the battery and have it tested this week. Others were mentioning a dirty throttle body or bad O2 sensors. The part about the display settings and radio being reset kinda does lead me to believe it may be a battery-related issue. I dont want to dump another dime in this thing. Ugh.... It was driving and starting just fine two weeks ago. Then it sat....and the weather got below freezing (dont know if that is related). Hope there is not something draining the battery while it sits.
hoodlum333 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.