Help! 4.0L Fuel? Problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > Help! 4.0L Fuel? Problems

1993-1998 Jeep Grand Cherokee Stainless Steel Exhaust Mani1996-1998 Jeep Grand Cherokee Header PanelBead Lock Wheels! Raceline, Trail Ready, & Trail-Gear

Reply
Unread 05-30-2012, 09:59 AM   #1
Braz
Registered User
 
Join Date: Aug 2002
Posts: 19
Help! 4.0L Fuel? Problems

Alright, so I'm nearly at my wits end trying to figure out my fuel problems.

Vehicle - 91 Comanche. 4.0L. 170k mi.

Problem - Jeep starts and idles fine. Drive OK while cold, warms up pretty quick. After warm, when starting from a dead stop, the Jeep stumbles heavily under throttle. (Very delicate throttle application does not cause a problem). If i stay on the gas, she'll die. If i let off it'll stumble for 15 seconds before coming back around (at which point i'll be at a dead stop).

I've replaced -
Fuel Pump (Bosch)
Plugs
Fuel Filter
Threw in newer (cleaner) injectors from my old 97 XJ (I assumed their compatible).

Before I went to the Bosch Pump, I had some buzzing coming from a cheap-o pump. I checked the pressures at that time and it was 29 and 37 with the vacuum plugged and unplugged, but I haven't checked it since I replaced the pump.
The Jeep had been cutting out under throttle but not nearly as bad, and died on a hot day (only had problems at temp again). So I had gone ahead and replaced the pump. Figured the cheap pump was still causing problems since it was buzzing, so I replaced it with a Bosch.

Could it be the FPR, even though previously my pressures were in range? I can't think of anything else that I could be.
From what I can tell, everything else on the Jeep is stock, most of it may be original. I had driven it for maybe 10k miles before it ever gave me any problems (aside from leaky injector delayed starting).

Thanks for any help,

Braz

Braz is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.