Hard Start and Flooding When Warm '90 YJ 2.5 - JeepForum.com

LinkBack Thread Tools
post #1 of 2 Old 01-12-2014, 08:47 AM Thread Starter
Registered User
1990 YJ Wrangler 
Join Date: Jan 2014
Location: Kansas City
Posts: 2
Hard Start and Flooding When Warm '90 YJ 2.5

Hey Guys, I need some help diagnosing an issue.

I've been working on my 1990 YJ 2.5 TBI and diagnosing a hot start issue.

The jeep seems to be running really rich when at idle and lean when at high rpms. Fuel pressure set at 10psi (prob a little low). It actually acts like it wants to die (sometimes) when I pull up to a stop. I do have an external pressure regulator and gauge set up. If I set the pressure to 8psi or less the issue goes away... but obviously, there isn't enough gas being supplied to run at load or drive very far.

It did have a faulty temp sensor and a dripping injector. After replacing those, she purrs great but the hot start issue is still there.Also, replaced the sparkplugs as the old ones were black.

It may be worth noting, that the TBI has dripping fuel, it appears out of the seals/screw of the pressure regulator (attached to the TBI). I'm assuming it's happening while running, but I can see the drip when the engine is off. Drips at a rate of about 2-3 drips a minute.

Any ideas/experience on this would be greatly appreciated!

mroz is offline  
Sponsored Links
post #2 of 2 Old 01-14-2014, 08:35 AM Thread Starter
Registered User
1990 YJ Wrangler 
Join Date: Jan 2014
Location: Kansas City
Posts: 2

Nobody have any ideas?
mroz is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome