JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   Engines & Drivetrain (http://www.jeepforum.com/forum/f19/)
-   -   Hard Start and Flooding When Warm '90 YJ 2.5 (http://www.jeepforum.com/forum/f19/hard-start-flooding-when-warm-90-yj-2-5-a-1987818/)

mroz 01-12-2014 08:47 AM

Hard Start and Flooding When Warm '90 YJ 2.5
 
Hey Guys, I need some help diagnosing an issue.

I've been working on my 1990 YJ 2.5 TBI and diagnosing a hot start issue.

The jeep seems to be running really rich when at idle and lean when at high rpms. Fuel pressure set at 10psi (prob a little low). It actually acts like it wants to die (sometimes) when I pull up to a stop. I do have an external pressure regulator and gauge set up. If I set the pressure to 8psi or less the issue goes away... but obviously, there isn't enough gas being supplied to run at load or drive very far.

It did have a faulty temp sensor and a dripping injector. After replacing those, she purrs great but the hot start issue is still there.Also, replaced the sparkplugs as the old ones were black.

It may be worth noting, that the TBI has dripping fuel, it appears out of the seals/screw of the pressure regulator (attached to the TBI). I'm assuming it's happening while running, but I can see the drip when the engine is off. Drips at a rate of about 2-3 drips a minute.

Any ideas/experience on this would be greatly appreciated!

mroz 01-14-2014 08:35 AM

Bump!

Nobody have any ideas?


The time now is 08:19 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.