getting sick of these tranny issues - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 07-02-2013, 08:07 PM Thread Starter
Stevusprime
Registered User
2004 KJ Liberty 
 
Join Date: May 2013
Location: drums
Posts: 7
getting sick of these tranny issues

I have an 04 jeep liberty sport (rocky mountain edition) 3.7 automatic

I am getting a grinding noise in first gear (sometimes it goes some times it just revs)
In reverse (when it goes) I get a pulsation like something is hanging up

The transmission was rebuilt back in april 2013 before I bought it...I have the receipts I was told it has a 1yr. Warranty on the rebuilsd but it seems I can't get a hold of the shop that did it.
Its my only car and I barely make it to and from work...
Are there any tests I can do or any ideas of what it could be?
I have a laundry list of codes but left them at work, I will post those tomorrow

Stevusprime is offline  
Reply

Tags
liberty , transmission

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome