Fuel Problem - JeepForum.com

LinkBack Thread Tools
post #1 of 2 Old 10-23-2001, 08:05 AM Thread Starter
Registered User
Join Date: Oct 2001
Location: Pennsylvania
Posts: 5
Fuel Problem

I have a 84 Wagoneer with a 2.5 engine. My problem is there is fuel in the oil, what is the cause of this? Bad fuel pump? Bad carb? anyone else have this problem? Thanks!

Mysta_Killa is offline  
Sponsored Links
post #2 of 2 Old 10-24-2001, 02:40 PM
glm 87 wrangler
Registered User
Join Date: Sep 2001
Location: Fayetteville NC
Posts: 271
sounds like the carb. It seems to be flooding
out.Check or have someone check the carb.your float maybe sticking.Does it run ok or does it try to cut off,can you smell fuel.Would like more info..on how it runs..

Gary 87 Wrangler 4.2 258 with weber carb and TFI upgrade.
31/10.5 and Nutter bypass!
glm 87 wrangler is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
HELP!! 4.0 fuel injector problem famous1688 Engines & Drivetrain 5 11-03-2008 02:19 PM
Fuel pressure problem TSEJEEPERS Engines & Drivetrain 0 11-25-2006 01:34 PM
Fuel problem SEZARO21 Engines & Drivetrain 4 10-26-2006 07:56 AM
93 YJ 4.0 HO fuel problem JeepCherokeeFan Engines & Drivetrain 1 07-20-2006 09:10 PM
360 Fuel \ Exhaust problem EvilJackBall Engines & Drivetrain 3 04-03-2004 07:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome