Engine stalls ??!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > Engine stalls ??!!

The Original 3/8" Ruffstuff Diff Cover!Building a Bumper?Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 09-02-2013, 10:35 AM   #1
cody413
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2013
Location: Port Charlotte, Florida
Posts: 178
Engine stalls ??!!

I have a 92 jeep wrangler yj. I just got a head job done. New fuel filter. New injectors. Cleaned out gas tank. New spark plugs. A lot is brand new. Runs fine till a couple days out of shop. I'll be driving and youl feel it bog a little bit. Then as soon as I stoo and put it in first and try and go. It stalls. Sometimes it will start after like 20 mins. I will have to hold gas pedal all the way down and you'll hear it starting to catch fuel n eventually pixk up and crank. Anyone ever had this happen? I also have a 4 cylinder. Id really have no clue

cody413 is offline   Reply With Quote
Unread 09-03-2013, 11:26 AM   #2
cody413
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2013
Location: Port Charlotte, Florida
Posts: 178
No one??!!
cody413 is offline   Reply With Quote
Unread 09-04-2013, 03:15 PM   #3
JeeperCreepers7
Registered User
 
Join Date: Sep 2013
Location: Athens, GA
Posts: 25
Is it a manual?
JeeperCreepers7 is offline   Reply With Quote
Unread 09-06-2013, 10:41 AM   #4
cody413
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2013
Location: Port Charlotte, Florida
Posts: 178
Yes it is. I've brought it to the shop. And of course it didn't happen. And they said its fine. The ride home it misfires/ boggs when putting it in gear while driving. And when I'm at a stop n give it gas just wants to stall. It'll clear up but take a min or so.
cody413 is offline   Reply With Quote
Unread 09-06-2013, 09:10 PM   #5
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla, florida
Posts: 1,901
Almost sounds fuel system related
__________________
http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline   Reply With Quote
Unread 09-08-2013, 07:16 PM   #6
copmedic309
Registered User
1995 XJ Cherokee 
 
Join Date: Sep 2013
Location: Woodbury, NJ
Posts: 65
Sounds like maybe a fuel pump, either that or check the crankcase position sensor
__________________
Ry.
Rather be tried by 12, than carried by 6.
copmedic309 is offline   Reply With Quote
Unread 09-08-2013, 07:44 PM   #7
cody413
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2013
Location: Port Charlotte, Florida
Posts: 178
Its something fuel related for sure. I'm gonna take it for a drive tomarrow and put a tester onvthe duel rail when it stalls. And see what I get. I was thinking some kind of sensor. Which is a lot cheaper than a fuel pump.
cody413 is offline   Reply With Quote
Unread 09-10-2013, 02:01 PM   #8
cody413
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2013
Location: Port Charlotte, Florida
Posts: 178
I checked the fuel pressure at the rail when it started bogging ouy. It was good. I also had my muffler blow open from the past. I replaced it. Someone told me it could be throwing off the back pressure which could mess with the oxygen sensor? I'm gonna get it home and start testing everything n hope to come across something. If anyone has ANY ideas please add. Thanks
cody413 is offline   Reply With Quote
Unread 09-10-2013, 07:59 PM   #9
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla, florida
Posts: 1,901
Check the cat see if it glowing. Sounds like it could be stopped up.
__________________
http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline   Reply With Quote
Unread 09-11-2013, 03:38 PM   #10
cody413
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2013
Location: Port Charlotte, Florida
Posts: 178
I had new injectors in it. Which sprayed morevit had 3 lil hole. So just guessing since it smelt strong of fuel when it bogged down. I put in the stock ones which were still good. Bogged but not as bad. N didn't smell to much of gas. Then I swithched out ignition coils. Old one was rusted. N also the TPS and drove around for a hour and no signs of anything. ight have found the problem
cody413 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.