Engine stalls ??!! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 10 Old 09-02-2013, 10:35 AM Thread Starter
cody413
Registered User
2006 LJ Wrangler 
 
Join Date: Jul 2013
Location: Port Charlotte
Posts: 233
Engine stalls ??!!

I have a 92 jeep wrangler yj. I just got a head job done. New fuel filter. New injectors. Cleaned out gas tank. New spark plugs. A lot is brand new. Runs fine till a couple days out of shop. I'll be driving and youl feel it bog a little bit. Then as soon as I stoo and put it in first and try and go. It stalls. Sometimes it will start after like 20 mins. I will have to hold gas pedal all the way down and you'll hear it starting to catch fuel n eventually pixk up and crank. Anyone ever had this happen? I also have a 4 cylinder. Id really have no clue

cody413 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 09-03-2013, 11:26 AM Thread Starter
cody413
Registered User
2006 LJ Wrangler 
 
Join Date: Jul 2013
Location: Port Charlotte
Posts: 233
No one??!!
cody413 is offline  
post #3 of 10 Old 09-04-2013, 03:15 PM
JeeperCreepers7
Registered User
 
Join Date: Sep 2013
Location: Athens
Posts: 25
Is it a manual?
JeeperCreepers7 is offline  
post #4 of 10 Old 09-06-2013, 10:41 AM Thread Starter
cody413
Registered User
2006 LJ Wrangler 
 
Join Date: Jul 2013
Location: Port Charlotte
Posts: 233
Yes it is. I've brought it to the shop. And of course it didn't happen. And they said its fine. The ride home it misfires/ boggs when putting it in gear while driving. And when I'm at a stop n give it gas just wants to stall. It'll clear up but take a min or so.
cody413 is offline  
post #5 of 10 Old 09-06-2013, 09:10 PM
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla
Posts: 1,961
Almost sounds fuel system related

http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline  
post #6 of 10 Old 09-08-2013, 07:16 PM
copmedic309
Registered User
1995 XJ Cherokee 
 
Join Date: Sep 2013
Location: Woodbury
Posts: 65
Sounds like maybe a fuel pump, either that or check the crankcase position sensor

Ry.
Rather be tried by 12, than carried by 6.
copmedic309 is offline  
post #7 of 10 Old 09-08-2013, 07:44 PM Thread Starter
cody413
Registered User
2006 LJ Wrangler 
 
Join Date: Jul 2013
Location: Port Charlotte
Posts: 233
Its something fuel related for sure. I'm gonna take it for a drive tomarrow and put a tester onvthe duel rail when it stalls. And see what I get. I was thinking some kind of sensor. Which is a lot cheaper than a fuel pump.
cody413 is offline  
post #8 of 10 Old 09-10-2013, 02:01 PM Thread Starter
cody413
Registered User
2006 LJ Wrangler 
 
Join Date: Jul 2013
Location: Port Charlotte
Posts: 233
I checked the fuel pressure at the rail when it started bogging ouy. It was good. I also had my muffler blow open from the past. I replaced it. Someone told me it could be throwing off the back pressure which could mess with the oxygen sensor? I'm gonna get it home and start testing everything n hope to come across something. If anyone has ANY ideas please add. Thanks
cody413 is offline  
post #9 of 10 Old 09-10-2013, 07:59 PM
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla
Posts: 1,961
Check the cat see if it glowing. Sounds like it could be stopped up.

http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline  
post #10 of 10 Old 09-11-2013, 03:38 PM Thread Starter
cody413
Registered User
2006 LJ Wrangler 
 
Join Date: Jul 2013
Location: Port Charlotte
Posts: 233
I had new injectors in it. Which sprayed morevit had 3 lil hole. So just guessing since it smelt strong of fuel when it bogged down. I put in the stock ones which were still good. Bogged but not as bad. N didn't smell to much of gas. Then I swithched out ignition coils. Old one was rusted. N also the TPS and drove around for a hour and no signs of anything. ight have found the problem
cody413 is offline  
Reply

Tags
fuel problem , stalls , wont start

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome