Engine problem solved! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > Engine problem solved!

Dana 30/ Dana 44 Chromoly shaft Kits- ECGSFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFlowmaster's Force II Axle-back exhaust system for the 201

Reply
Unread 07-12-2013, 08:43 AM   #1
Historynut
Registered User
1967  
 
Join Date: Mar 2011
Location: Santa Rosa, CA
Posts: 5
Engine problem solved!

Some time ago I mentioned I could not figure out for the life of me why I couldn't get my blankety-blank F4 engine to run properly. After a lot of work I found out the rebuilt YF carburetor purchased from Kaiser-Willys had an undersize main jet. After a couple of tries of drilling it out about another three thousanths in diameter, it runs fine! It came from the rebuilders running too lean. Nice to have my Jeep back!

Historynut is offline   Reply With Quote
Unread 07-13-2013, 06:48 AM   #2
hotrod351
Registered User
1955 M-38 
 
Join Date: Oct 2006
Location: arizona
Posts: 437
good that you figured that one out. one of those things that youd never expect.
hotrod351 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.