Engine knock - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 09-06-2013, 04:11 PM Thread Starter
PerkinsTJ
Registered User
1999 TJ Wrangler 
 
Join Date: Nov 2011
Location: kingsville
Posts: 9
Engine knock

Hey I've got a 1999 jeep wrangler se 2.5l 4cy manual with 285xxxkm


I've got a engine knock seems to only come while temp is normal not there while cold.

Coming from passenger side on the engine but can really hear it from underneath.

Oil pressure is still looking good, temp is good

My rpm at idle is a tin bit bouncy.

Also for extra info my front o2 sensor hit the bucket about 4 months ago, unplugged it and mileage almost back to normal.

Will post a video with the sound once I find out how too.

Thanks

PerkinsTJ is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 09-06-2013, 09:00 PM
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla
Posts: 1,961
Easiest way for videos is to make free YouTube account and post vid there.

Could be piston slap that happens with temp. Wrist pin too.
Does it change with throttle?

http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline  
post #3 of 8 Old 09-07-2013, 10:18 AM Thread Starter
PerkinsTJ
Registered User
1999 TJ Wrangler 
 
Join Date: Nov 2011
Location: kingsville
Posts: 9
http://youtu.be/ascDBHbyLu8
PerkinsTJ is offline  
 
post #4 of 8 Old 09-07-2013, 09:09 PM
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla
Posts: 1,961
It almost sounds like a valve in the head. That goes along with your symptoms. Maybe burnt or bent.
Hard to tell with s video but that was one of the best videos yet.
Have you tried to put your hand by the exhaust pipe? Try that see if it feels steady or has a slight miss to it.

http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline  
post #5 of 8 Old 09-08-2013, 11:59 AM Thread Starter
PerkinsTJ
Registered User
1999 TJ Wrangler 
 
Join Date: Nov 2011
Location: kingsville
Posts: 9
Yes It does have a slight miss in the flow, that only happens when it's at warm temp too
PerkinsTJ is offline  
post #6 of 8 Old 09-08-2013, 04:45 PM
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla
Posts: 1,961
Sounds like a valve. Couldn't guess how much time you have.
That's a lot miles on a 4 Banger

http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline  
post #7 of 8 Old 09-08-2013, 09:13 PM Thread Starter
PerkinsTJ
Registered User
1999 TJ Wrangler 
 
Join Date: Nov 2011
Location: kingsville
Posts: 9
When I bought the jeep at 280xxx he rebuilt the head on it, maybe he fudged up something.

Any tips on fixing this or seeing if its actually a valve?
PerkinsTJ is offline  
post #8 of 8 Old 09-09-2013, 07:07 PM
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla
Posts: 1,961
Valves are tricky. Take it to a machine shop. Let them take a peek. More than likely the head will have to come off.

http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome