Engine has trouble starting - JeepForum.com
 
LinkBack Thread Tools
post #1 of 7 Old 06-22-2013, 08:48 PM Thread Starter
bmxchan
Registered User
1993 ZJ 
 
Join Date: Oct 2012
Location: Christiansburg
Posts: 43
Engine has trouble starting

Alright guys so here it is and I've searched for it but can't find what I need. I have got a 89 yj with the 2.5l so it does have a carb. And yes the battery is good. Sometimes when I try to start my jeep it won't start but if you wait for maybe 5-10 min it will all the sudden come to life when you try it again. It will also sometimes do it if you stall then try to start back up but other times it will be fine. Any help would be appreciated! Don't wanna get stranded somewhere!

bmxchan is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 06-23-2013, 03:08 PM Thread Starter
bmxchan
Registered User
1993 ZJ 
 
Join Date: Oct 2012
Location: Christiansburg
Posts: 43
Do you guys think it would be a starter/selinoid problem?
bmxchan is offline  
post #3 of 7 Old 06-23-2013, 10:18 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,037
89 YJ 2.5 with carb? Sure about that?

If you own a Renix Jeep, you'll want to check this out.

An index to over 30 write-ups can be found in the link below

www.cruiser54.com

My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline  
post #4 of 7 Old 06-25-2013, 08:36 AM Thread Starter
bmxchan
Registered User
1993 ZJ 
 
Join Date: Oct 2012
Location: Christiansburg
Posts: 43
Quote:
Originally Posted by cruiser54
89 YJ 2.5 with carb? Sure about that?
Yeah I'm sure
bmxchan is offline  
post #5 of 7 Old 06-25-2013, 08:55 AM
LtCdrLange
Registered User
1997 XJ Cherokee 
 
Join Date: Jun 2013
Location: Apache Junction
Posts: 7
bmx, try the crank position sensor. all jeeps seem to have this problem. when it fails it'll either a) not start or b) run for maybe 20 minutes then stall out. I had this problem on my straight 6. It usually sits on top of the bell housing by the firewall
LtCdrLange is offline  
post #6 of 7 Old 06-25-2013, 10:04 AM Thread Starter
bmxchan
Registered User
1993 ZJ 
 
Join Date: Oct 2012
Location: Christiansburg
Posts: 43
Quote:
Originally Posted by LtCdrLange
bmx, try the crank position sensor. all jeeps seem to have this problem. when it fails it'll either a) not start or b) run for maybe 20 minutes then stall out. I had this problem on my straight 6. It usually sits on top of the bell housing by the firewall
Well after I get it started it runs fine, most of the time the jeep with start the first try but sometimes she just won't turn over so I wait for about 5 minutes and she will start right up! It's very random in my opinion. That's why I thinks it's the starter/selinoid
bmxchan is offline  
post #7 of 7 Old 06-25-2013, 02:32 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,037
Quote:
Originally Posted by LtCdrLange View Post
bmx, try the crank position sensor. all jeeps seem to have this problem. when it fails it'll either a) not start or b) run for maybe 20 minutes then stall out. I had this problem on my straight 6. It usually sits on top of the bell housing by the firewall
If it's carbureted, it has no CPS.

If you own a Renix Jeep, you'll want to check this out.

An index to over 30 write-ups can be found in the link below

www.cruiser54.com

My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome