post #1 of Old 10-09-2008, 03:25 PM Thread Starter
tarilas10
Registered User
 
Join Date: Oct 2008
Location: Texas
Posts: 1
Engine almost stalls after each start.

I have a problem with my 99 Jeep Cherokee SE(4.0). Each time I start the engine and go for about 1/4 of a mile, the engine starts to sputter and lose power, but does not stall. After about 3 to 4 seconds, the problem goes away until the next time I start up the engine again. I have replaced the crank position sensor and the ECU to no avail. Check codes and there are no codes, no check engine light. Also replaced spark plugs and distributor rotor and cap. Any suggestions?


Last edited by tarilas10; 10-09-2008 at 03:42 PM.
tarilas10 is offline  
post #2 of Old 10-09-2008, 08:05 PM
1968charger666
Registered User
1991 YJ Wrangler 
 
Join Date: Jan 2008
Location: Indiana
Posts: 33
Try some fuel injector cleaner. The throttle position sensor might be acting up, maybe check that.

-1991 YJ, 2.5L I-6, AX-5, NP231, SYE, Terralow 4:1, D30 & D35 w/ 4.88's & lockers, all w/warn lockout hubs, Procomp coil overs, 9" lift total, 35X15.5R15 Siped Super Swampers, Warn Bumpers, brush guard, Belly and Fuel tank skid plate, Herc'd tub, Dents and scratches
1968charger666 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Heres one. Key CB Mic and engine stalls 92 Green YJ Stereos, CB & Ham Radios, GPS, & Electrical. 15 07-23-2015 06:14 PM
Engine stalls while idling GlennG Engines & Drivetrain 5 01-05-2012 08:40 AM
HELP!! Engine stalls out after new tranny install SoCalDevyn Engines & Drivetrain 3 02-04-2009 11:17 PM
No engine power, off & on acceleration, stalls out richbrooks11 Engines & Drivetrain 6 10-31-2008 08:09 PM
engine stalls when brakes are applied dhammonds2369 Engines & Drivetrain 6 02-28-2004 05:56 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome