Emergency! 91 XJ - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 07-10-2013, 10:19 AM Thread Starter
Thiefroku
Registered User
1995 YJ Wrangler 
 
Join Date: Dec 2010
Location: Hatboro
Posts: 39
Emergency! 91 XJ

I was driving on I 70 in Ohio and the jeep just made a pop noise and then wouldn't accelerate. I pulled her over and then the power cut off and she won't fire up. Crank but won't fire. Any advice? I had the fog lights blow a fuse and locked the computer before. Could it be this again?

Thiefroku is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome