Drivetrain problem - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 04-15-2013, 10:42 AM Thread Starter
06libertylimit
Registered User
2006 KJ Liberty 
 
Join Date: Apr 2013
Location: bonifay
Posts: 3
Drivetrain problem

was shifting out of full time 4 wheel drive back to 2 wheel drive and heard an awful popping/grinding noise coming from underneath the front of the vehicle so i pulled over shifted the 4x4 into neautral and back down to 2-wheel drive now my jeep wont go forward or backward in any gear and it also seems like the 4x4 shifter cable has disconnected. PLEASE HELP... 2006 jeep liberty limited 3.7 liter

06libertylimit is offline  
Reply

Tags
4x4 not working , gear question , tranny problem

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome