cyclop ain't working??? -

LinkBack Thread Tools
post #1 of 1 Old 10-24-2011, 04:06 PM Thread Starter
Registered User
2004 TJ Wrangler 
Join Date: Oct 2011
Location: montreal
Posts: 30
cyclop ain't working???

on my inspection sheet it says the cyclop and oil back up ain't working...

I have been looking on the web and on the forums this week end and I can't find out wtf is a cyclop. All I get is information about the mythical creature. :S

Could anyone help me please? I need to know what it is and how much would it cost to replace it thx.

Shmee is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Amp working? 4x4Jeep Audio, CB & Ham Radios, GPS, & Electrical 3 06-29-2011 09:52 AM
fan not working RKOTAREK Audio, CB & Ham Radios, GPS, & Electrical 2 07-29-2009 03:59 PM
Horn on 97 ZJ stopped working, but then started working again? compcrasher86 Audio, CB & Ham Radios, GPS, & Electrical 0 01-09-2009 03:15 PM
sub not working Guitarhead09 Audio, CB & Ham Radios, GPS, & Electrical 4 09-20-2007 11:07 PM
KCs not working Nymisus General Jeep & Off-Road Equipment 4 06-30-2004 09:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome