Crank no start - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > Crank no start

Premium LED Lighting by VISION X, Proudly sold at ROCKRIDGFS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectCess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WD

Reply
Unread 11-21-2013, 11:52 PM   #1
WKJeeper05
Registered User
 
Join Date: Nov 2013
Posts: 5
Crank no start

93 cherokee. 4.0. Cranks like crazy but won't kick or start. I've checked the CPS w another and it good. Tired throttlebody(tps included) with a good one no luck. I'm getting good spark. I've got compression. It just won't kick over or start. It will crank great though. Any help much appreciated

WKJeeper05 is offline   Reply With Quote
Unread 11-22-2013, 12:23 AM   #2
awolkiwi
Registered User
 
Join Date: Sep 2013
Posts: 3
Only leaves fuel would be my next avenue
awolkiwi is offline   Reply With Quote
Unread 11-22-2013, 12:33 AM   #3
shadowridr1
Registered User
2005 LJ Wrangler 
 
Join Date: Apr 2013
Location: Iowa Park, Texas
Posts: 74
gotta have 3 things to make and engine run

fire
fuel
air

only one you didnt mention was fuel.
shadowridr1 is offline   Reply With Quote
Unread 11-22-2013, 12:46 AM   #4
WKJeeper05
Registered User
 
Join Date: Nov 2013
Posts: 5
Fuel is good. Got great pressure. That's why I turned to the threads. Have spark, fuel and compression. At a loss at the moment
WKJeeper05 is offline   Reply With Quote
Unread 11-22-2013, 03:35 AM   #5
shadowridr1
Registered User
2005 LJ Wrangler 
 
Join Date: Apr 2013
Location: Iowa Park, Texas
Posts: 74
Wonder if it jumped time??? I had an old Chevy that did that once. Took me forever to figure that out. But with this being computer controlled. Have you checked for codes.
shadowridr1 is offline   Reply With Quote
Unread 11-22-2013, 03:36 AM   #6
shadowridr1
Registered User
2005 LJ Wrangler 
 
Join Date: Apr 2013
Location: Iowa Park, Texas
Posts: 74
Well you said you did the CPS so that should rule out the timing thing.
shadowridr1 is offline   Reply With Quote
Unread 11-22-2013, 10:09 PM   #7
higgins192
Registered User
1999 TJ Wrangler 
 
Join Date: Dec 2010
Location: Annapolis, Maryland
Posts: 249
Check and clean your camshaft position sensor, it is in your distributor cap under the rotor. Because its magnetic and metal shaving can clog the sensor. Also check your crankshaft position sensor it's on the bell housing it's worth replacing they can go bad at a moments notice and not throw a code. Happened to me. Also just check your ignition coil pack to make sure it's getting real good spark. The problem with ignition problems is you can't pinpoint them. It's kinda process of elimination
higgins192 is offline   Reply With Quote
Unread 11-23-2013, 05:00 AM   #8
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla, florida
Posts: 1,934
Auto kill relay under hood. Also check the fuel pump resistor under hood.
Weak coil?
Battery voltage. Under 10ish and the ecm won't let it start.
__________________
http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline   Reply With Quote
Unread 11-23-2013, 04:01 PM   #9
copmedic309
Registered User
1995 XJ Cherokee 
 
Join Date: Sep 2013
Location: Woodbury, NJ
Posts: 65
Try starting it in drive or reverse. If it starts up, could be your NSS cheaper to take apart and clean than to replace
__________________
Ry.
Rather be tried by 12, than carried by 6.
copmedic309 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.