JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   Engines & Drivetrain (http://www.jeepforum.com/forum/f19/)
-   -   coolant system problems (http://www.jeepforum.com/forum/f19/coolant-system-problems-1475382/)

MattNey723 02-07-2013 10:36 AM

coolant system problems
 
I cracked my radiator about 2 weeks ago replaced it twice since then now I have no heat and my thermostat housing cracked... I'm good with anything else in a jeep but the cooling system of an 01. Any suggestions or advice?

benc85 08-22-2013 12:45 AM

Quote:

Originally Posted by MattNey723
I cracked my radiator about 2 weeks ago replaced it twice since then now I have no heat and my thermostat housing cracked... I'm good with anything else in a jeep but the cooling system of an 01. Any suggestions or advice?

I have the same problem mate. Just put new one in and still getting very hot. The fan seems to be blowing air on to radiator not sucking fresh air in. I tried to turn around but its same other way. Have you sorted yours out yet?

uberxj92 08-22-2013 09:50 PM

This is weird but it sounds like you guys put your thermostats in backwards.
As for the fan blowing backwards even if you turn it around, that sounds like you somehow plugged it I'm backwards.
Did you guys change out the radiator hoses?
No heat could be ( aside from the thermostat backwards ) could be the heater control valve maybe it caused your original overheating. Check the vacuum line make sure its connected.

andyabbot 08-23-2013 01:03 AM

Here is only one way to fix that issue you have to install the new radiator in the jeep because jeep will get hotter if you did not fix that issue and it will cause the major damage.
United Car Care

uberxj92 08-23-2013 06:25 AM

Quote:

Originally Posted by andyabbot (Post 15826673)
Here is only one way to fix that issue you have to install the new radiator in the jeep because jeep will get hotter if you did not fix that issue and it will cause the major damage.

They did replace the radiators with new ones.

laybackman 08-23-2013 08:19 AM

Then the water pump is probably spinning the wrong way. Many jeeps have reverse direction water pumps.

EDIT!! IF the T-stat is in right.

uberxj92 08-23-2013 12:39 PM

Check belt to make sure its routed right


The time now is 10:20 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.