Cold Weather - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 01-06-2014, 10:49 PM Thread Starter
Jimidude87
Registered User
1988 YJ Wrangler 
 
Join Date: Aug 2011
Location: spring hill
Posts: 90
Cold Weather

So I live in Florida and the past few days it got chili...and since it got cold my jeep has been running like crap. It idles fine but as soon as I take off there is like no power and it wants to backfire frequently...I just put new plugs and wires and I know they are fine because I drove in the heat with them installed and it ran fine...it doesn't matter if the motor is warm it still drives bad...only in the cold though...is this just something I will have to get used to in my jeep or is there a solution to this problem? I figured the air/fuel ratio is just off because of the cold weather but didn't want to adjust the carb because I'm sure it will be warm out next week again...I have an 88 wrangler with a 4.2 and a manual transmission...any thoughts and ideas are greatly appreciated

Jimidude87 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-08-2014, 02:31 PM
Red Rubicon
Registered User
2003 TJ Wrangler 
 
Join Date: Jun 2002
Location: Mt. Shasta, Ca
Posts: 208
Many possibilitys; lean carb. thermostat not warming engine, heated air tube to air cleaner missing, timing out of spec.
Red Rubicon is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome