Reply
 
LinkBack Thread Tools
post #16 of Old 06-02-2012, 10:23 PM Thread Starter
Ruffnek
Registered User
1998 XJ Cherokee 
 
Join Date: Oct 2006
Location: Calgary
Posts: 110
Quote:
Originally Posted by laybackman View Post
Since you installed the timing chain set improperly the crank and cam signal are not in sync according to your factory presets in the PCM.

The crank sensor looks for movement and sends a signal to the PCM when it does detect movement. If none is 'seen' you get no spark and no fuel.

I think the cam sensor only times the firing of the plugs. So you adjusted the distributer by swinging the rotor back to make it right or you rewird the plug wires to make it right. Now it runs just fine, BUT the cam and crank sensor signals are not sync'ed. That must be why it runs just fine but the CEL is on. The fix: a 1" piece of electrical tape over the CEL...
Could be, except I took the timing set out and replaced it properly :P Black tape would work, lol, but I never like those kinds of fixes. I think I'm gonna contact Comp Cams and see what they say.



Ruffnek is offline  
Reply

Tags
cam position sensor , check engine light , crank position sensor


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
trouble after engine swap 3.7L. different crank position ring on crank nubby Engines & Drivetrain 1 06-13-2009 05:48 PM
Where is the Crankshaft Position Sensor??? ScottN3N Engines & Drivetrain 2 11-26-2008 10:35 PM
EGR position sensor? delta490 Engines & Drivetrain 0 05-14-2008 11:09 AM
Cam Position Sensor AZG23 Engines & Drivetrain 0 03-02-2006 10:46 AM
Flywheel/Driveplate/Flexplate and Crank Position Sensor jeeprad Engines & Drivetrain 2 11-29-2002 10:01 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome