Check Engine, Crank AND Cam position sensor codes - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > Check Engine, Crank AND Cam position sensor codes

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineOfficial Chassis Saver Rust Preventive Truck & Auto UnFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 06-02-2012, 10:23 PM   #16
Ruffnek
Registered User
1998 XJ Cherokee 
 
Join Date: Oct 2006
Location: Calgary
Posts: 110
Quote:
Originally Posted by laybackman View Post
Since you installed the timing chain set improperly the crank and cam signal are not in sync according to your factory presets in the PCM.

The crank sensor looks for movement and sends a signal to the PCM when it does detect movement. If none is 'seen' you get no spark and no fuel.

I think the cam sensor only times the firing of the plugs. So you adjusted the distributer by swinging the rotor back to make it right or you rewird the plug wires to make it right. Now it runs just fine, BUT the cam and crank sensor signals are not sync'ed. That must be why it runs just fine but the CEL is on. The fix: a 1" piece of electrical tape over the CEL...
Could be, except I took the timing set out and replaced it properly :P Black tape would work, lol, but I never like those kinds of fixes. I think I'm gonna contact Comp Cams and see what they say.



Ruffnek is offline   Reply With Quote
Reply

Tags
cam position sensor , check engine light , crank position sensor
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.