post #1 of Old 04-16-2012, 08:07 AM Thread Starter
reaxion911
Registered User
 
Join Date: Jan 2012
Posts: 81
Bump throttle?!

To start 2000 tj 2.5 w 4.0 tb on 31s. The only way i can explain this is after i installed my 4" lift i have this issue where it sounds like the jeep is bumping off of the engines power or bouncing off of it if you will. Its really bad in the the slow bumpy stuff especially after installing the tb and lubing the cable as my peddle is very touchy. Ive put a hand throttle in the make it easier to contend with but i think its time to address the problem. My first thought is that my motor mounts cold be worn out? Next would be that i only replace the lower con arms with my lift and im thinking the upper con arm bushings are worn out causing wrap causing this whole bounce thing. Any thoughts guys! Any help or suggestions would be greatly appreciated. Oh and i know owning a 4 cyl to jeepers is like owning a sportster to bikers but please dont bash its my bad choice and i know i have to live with it.

reaxion911 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome