Auto Transmission Delay into Drive on LJ 4-speed auto - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 07-31-2013, 01:29 PM Thread Starter
TFERV
Registered User
2004 LJ Wrangler 
 
Join Date: Jan 2013
Location: Goshen
Posts: 249
Auto Transmission Delay into Drive on LJ 4-speed auto

I have a 2004 Wrangler Unlimited (2-door LJ) which has the 42LRE 4-speed auto transmission. I just had the transmission rebuilt and installed a new billet torque converter and Level 2 shift kit.

The rebuild made a big difference; however, the transmission still takes a second or 2 to engage when going from Park to Drive. This mostly just happens once the trany is warmed up. The rebuild made this issue much better but it still does it. When I first put it in drive it makes a buzzing sound (like it is trying to engage) before it engages. If I throttle before it engages (before the buzzing stops) it makes a "clunk, clunk, clunk" sound and then engages. This is the only issue other than that the trany works great.

If you know what the issue could be that would be great! Thanks


TFERV
94 ZJ 3"lift 31s Bigger build in process
SOLD 04 LJ 3" lift, 33 Falkens, Bumpers, Trektop...
TFERV is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome