AMC 20 bent - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 05-01-2012, 02:23 PM Thread Starter
mark123
Registered User
1985 CJ7 
 
Join Date: Jul 2010
Location: PEI Canada
Posts: 18
AMC 20 bent

I am getting more wear on my rear right tire and I think the axle tube must be slightly bent where it is pressed into the housing, can this be straightened? Also looking at the rear shackles from the rear they are out wider at the bottom than the top.

mark123 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
bent rod Mudslinger1975 Engines & Drivetrain 3 03-22-2012 07:38 AM
need to get some tube bent crazycollinz Fabrication Shop 5 09-10-2009 06:04 PM
Bent Tailgate papa_panda General Jeep & Off-Road Equipment 1 02-12-2008 02:59 PM
bent Tie Rod Trail fix 1CleanTJ Cheap Tricks & Fixes 1 12-19-2007 08:56 PM
Bent frame? Cajunzj General Jeep & Off-Road Equipment 1 05-12-2007 04:53 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome