alternater troubles - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 04-08-2012, 08:38 AM Thread Starter
bmiller91XJ
Registered User
 
Join Date: Mar 2012
Posts: 14
alternater troubles

I have a ? My alternater on my91 Cherokee has gone bad on me twice to weekends in a row . It happens when I get in some water any ideas on how to fix maybe make something so the water don't rush in there . I don't know its just starting to get on my nerves I haven't been able to go wheeling with out it giving me troubles. Any ideas would be appreciated . Thanks

bmiller91XJ is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-08-2012, 03:36 PM
vwtipeii
Member
 
vwtipeii's Avatar
1994 YJ Wrangler 
 
Join Date: Apr 2011
Location: Hermosa Beach
Posts: 301
Drive slower through water obstacles... Or avoid them... Or carry a spare alt w you...
vwtipeii is offline  
post #3 of 6 Old 04-08-2012, 04:15 PM Thread Starter
bmiller91XJ
Registered User
 
Join Date: Mar 2012
Posts: 14
Well yeah I know that didn't go fast. And its kinda hard to avoid them but I do try for the most part and but sometimes the mud hole is deeper then it looks lol but good advice
bmiller91XJ is offline  
post #4 of 6 Old 04-08-2012, 11:39 PM
ClimbStuff
Registered User
2003 TJ Wrangler 
 
Join Date: Aug 2009
Location: Trinidad
Posts: 1,229
I've never had a problem with an alternator going out from water... I regularly blast mine with a power washer, and done plenty of water crossing with it... 9yrs old and it works just fine. Perhaps there is another issue...?
ClimbStuff is offline  
post #5 of 6 Old 04-09-2012, 10:57 AM Thread Starter
bmiller91XJ
Registered User
 
Join Date: Mar 2012
Posts: 14
Yeah I have thought of that to but I found on here that people have relocated it to where the a/c unit is. Witch I am thanking of doing if I can figure out how it was done . Would love to see pics of it
bmiller91XJ is offline  
post #6 of 6 Old 04-16-2012, 04:19 PM Thread Starter
bmiller91XJ
Registered User
 
Join Date: Mar 2012
Posts: 14
Quote:
Originally Posted by ClimbStuff
I've never had a problem with an alternator going out from water... I regularly blast mine with a power washer, and done plenty of water crossing with it... 9yrs old and it works just fine. Perhaps there is another issue...?
U have any ideas ? It could have been the thick Ohio mud to maybe ?
bmiller91XJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome