air temp sensor - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 05-24-2012, 11:07 PM Thread Starter
25greenwrangler
Registered User
1997 TJ Wrangler 
 
Join Date: Aug 2011
Location: Hull
Posts: 163
air temp sensor

so I did the whole lack and ats cleaning and what a difference!! but after about an hour it went back to the way it was. anny ideas on what to do next? the ats was covered in this black sludge if that helps


why buy when you can build?
25greenwrangler is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-26-2012, 01:01 PM Thread Starter
25greenwrangler
Registered User
1997 TJ Wrangler 
 
Join Date: Aug 2011
Location: Hull
Posts: 163
idle air control and manifold temperature sensor called it the wrong thing

why buy when you can build?
25greenwrangler is offline  
post #3 of 6 Old 05-26-2012, 10:33 PM
jnicewan
Registered User
1995 ZJ 
 
Join Date: Dec 2010
Location: Norman
Posts: 2,348
What kind of problem are you having? If I understand correctly you cleaned the IAC and IAT (idle air control valve, intake air temp sensor)? did you clean the passage for the IAC and did you clean the throttle body too? After doing that did you reset the PCM, or unplug the battery for a couple mins? Resetting PCM is usually a good idea because it lets the PCM relearn idle strategy.
jnicewan is offline  
post #4 of 6 Old 05-28-2012, 09:59 PM Thread Starter
25greenwrangler
Registered User
1997 TJ Wrangler 
 
Join Date: Aug 2011
Location: Hull
Posts: 163
pour fuel economy hesitation and whenever I start kt after the first ten declines of running it almost stalls then comes back, cleaned the passages and reset the ecu by disconnecting the battery.plugs, wires are all good checked the D'OH! items. so far some of my interntet research seems to go with my theft
also did a test using a vom and it failed horebly

why buy when you can build?
25greenwrangler is offline  
post #5 of 6 Old 05-28-2012, 10:00 PM Thread Starter
25greenwrangler
Registered User
1997 TJ Wrangler 
 
Join Date: Aug 2011
Location: Hull
Posts: 163
pour fuel economy hesitation and whenever I start kt after the first ten declines of running it almost stalls then comes back, cleaned the passages and reset the ecu by disconnecting the battery.plugs, wires are all good checked the D'OH! items. so far some of my interntet research seems to go with my theft
also did a test using a vom and it failed horebly

why buy when you can build?
25greenwrangler is offline  
post #6 of 6 Old 06-03-2012, 07:16 PM Thread Starter
25greenwrangler
Registered User
1997 TJ Wrangler 
 
Join Date: Aug 2011
Location: Hull
Posts: 163
update:replaced the air temp sensor at a cost of 18 bucks, engine runs smoother but still lacks power,although power seems to come back the more I drive it(I only drove it 3 miles) oh and I unhooked the negative battery terminal for 10 minutes to reset the pcm andmy question is this since iv had this problem for 4 years, does it take pcm a long time to relearn with the right signals? or should it do that instantly? and as a bonus somehow the engine ticking is quieter.

why buy when you can build?
25greenwrangler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
tranny temp sensor richardclarkjr General Jeep & Off-Road Equipment 1 05-15-2012 02:31 PM
2000 xj temp sensor Supertrooper50 Engines & Drivetrain 0 04-11-2012 08:07 PM
temp sensor for tranny richardclarkjr Engines & Drivetrain 3 04-01-2012 12:56 AM
temp sensor for gauge, where is it? willyb8 Stereos, CB & Ham Radios & GPS & Electrical. 3 03-04-2009 06:05 PM
coolant temp sensor teenwolf1393 Engines & Drivetrain 0 05-17-2007 02:36 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome