post #1 of Old 03-15-2014, 10:34 PM Thread Starter
jeeparoonie
Registered User
1995 ZJ 
 
Join Date: Mar 2014
Location: Blue Mound
Posts: 1
acceleration

hey i have a 1995 jeep grand cherokee, i got it with 160,000 on it, and idk how much is on the transmission, guessing its the stock one. but on to the problem, so when i try to accelerate fast when going slow, it will accelrate fast and shoot the rpms up normally and it will accelerate to 55 normaly fast, but when i go to pass a car going 55, and try to accelerate fast to get around them, my jeep wont accelerate fast, the rpms shoot up like it should, but my speed bearly climbs. so i put a new cool air intake, thinking it would solve the problem, but its the same. im guessing i just need a new tranny, but if someone else knows what the problem might really be, im hoping to get some help, thank you.

jeeparoonie is offline  
post #2 of Old 03-22-2014, 09:53 PM
mrjonshepherd
Registered User
 
Join Date: Mar 2014
Posts: 4
Try turning the overdrive off if you can
mrjonshepherd is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome