98 xj no spark nopower to pump at all and no volt or fuel gauges - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > 98 xj no spark nopower to pump at all and no volt or fuel gauges

** FALL SALE on all Jeep Optic Armor Windshields **Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineBead Lock Wheels! Raceline, Trail Ready, & Trail-Gear

Reply
Unread 04-07-2012, 10:33 PM   #1
dfireman
Registered User
1998 XJ Cherokee 
 
Join Date: Apr 2012
Location: gentry, ar
Posts: 2
98 xj no spark nopower to pump at all and no volt or fuel gauges

hello im new to the jeep world so i will tell story from start and hope i can get help here. i bought a 98 jeep xj 4x4 with 250000 miles when i bought it it ran fine just needed shocks. after driving it and putting new brakes and wheel cylenders on it i got a 4.5 inch lift. the battery had a bad cell so i jumped it ro get it to the alighnment shop. after they finished the work in it they drove it and put it on rack to finish it up. went to start it and no go. i went to shop and put 10 gal of fuel in it thinking that sence there was no fuel on gauge some one stole my fuel. still no change. read on here bout the cps so i replaced it still no spark no power to pump and no fuel or voltage! being a diesel mechanic i thought i could figure it out but im lost. could the napa sensor bebad? it tested good tho. i have no 5v at plugs with key on. also cant hook to it with my matco scaner but my cheep actron one pulls up a p1694 i think.. i know it said to ohm wires between the tcm and pcm did that and the purple is a little high. started tracing it and found it splits off to frrd power to turn signals too. but no bad spots that i can tell.



i need help bad have no one that i know that is good with jeeps. dont wanna sell it cause i want something for my family to have fun in. please help me

p.s. i replaced the battery also.


thanks
David

dfireman is offline   Reply With Quote
Unread 04-12-2012, 05:33 AM   #2
dfireman
Registered User
1998 XJ Cherokee 
 
Join Date: Apr 2012
Location: gentry, ar
Posts: 2
Any one have any ideas? I guess I will order a PCM for it.
dfireman is offline   Reply With Quote
Unread 04-12-2012, 05:45 PM   #3
dusterdude
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: hopewell, va
Posts: 2,044
Thats too weird for it to die at the shop
dusterdude is offline   Reply With Quote
Unread 04-14-2012, 04:39 PM   #4
tslroper
Registered User
1990 YJ Wrangler 
 
Join Date: Aug 2010
Location: New Mexico
Posts: 380
Sorry, not sure how this got posted to the wrong thread...
__________________
1990 YJ Islander, 4.2L MC2100 DUI HEI, 2.5" RE lift, 31x10.50 DuraTracs, HandenFab rear bumper / swing-out, Tough Terrain
off-road camp trailer.
Build thread: http://www.jeepforum.com/forum/f22/tys-yj-build-1502554/
tslroper is offline   Reply With Quote
Unread 07-06-2012, 06:13 PM   #5
thegreenbastard
Registered User
 
Join Date: Jun 2012
Posts: 3
I have the same problem with my 98 xj I replaced the crank sensor tried the asd relay and nothin I don't know what to do with it either! Is the computer toast? I got the same p1694 on the obd and if u look it up it means it's not reading anything (or so I found when I googled it) somebody help us!!
thegreenbastard is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.