98 limited 5.9, hard to crank - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 02-12-2011, 08:32 AM Thread Starter
bathroomonkey
Registered User
1998  
 
Join Date: Feb 2011
Location: columbia
Posts: 8
98 limited 5.9, hard to crank

hard to crank when cold. once its cranked it runs perfect. once its warm it cranks perfect. looked for a fuel filter, didnt see one in the frame rails where i thought it was, havin trouble findin a haynes manual for the 5.9 model.
any ideas? or am i way off all together?
bm

bathroomonkey is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
98 jeep cherokee limited 5.9, hard to start bathroomonkey Engines & Drivetrain 0 02-12-2011 08:27 AM
just bought a 98 5.9 limited. hard to start. bathroomonkey Engines & Drivetrain 0 02-12-2011 08:23 AM
trouble after engine swap 3.7L. different crank position ring on crank nubby Engines & Drivetrain 1 06-13-2009 05:48 PM
4.0 hard crank and power tops out yunkj17 Engines & Drivetrain 5 12-27-2008 08:00 PM
4.0/242 Crank in a 4.2/258? SFJs Engines & Drivetrain 1 02-04-2008 08:40 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome