JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   Engines & Drivetrain (http://www.jeepforum.com/forum/f19/)
-   -   98 I6 Grand Cherokee Sputtering (http://www.jeepforum.com/forum/f19/98-i6-grand-cherokee-sputtering-1531666/)

jvillalp7 06-03-2013 02:29 AM

98 I6 Grand Cherokee Sputtering
 
I have a 98 Grand Cherokee I6 that sputters and wants to stall every so often now that summer is here in Las Vegas,Nv. I had the Camshaft sensore replaced last year, it was the cause of me stalling out whenever I would get to running temp. A week ago I ran the A/C for about 10 minutes while idling then shut off. for about 10 minutes. Then the start up seemed rough and sounded/felt like it would stall. I revved the engine and sure enough it sounded brand new. And then today I started up just fine going through my neighborhood it didn't want to go past 20mph, sputtering and such about to stall, so I slammed the gas and it seemed to clear the problem for the day

Speedymcracer01 06-03-2013 02:40 AM

Quote:

Originally Posted by jvillalp7 (Post 15512712)
I have a 98 Grand Cherokee I6 that sputters and wants to stall every so often now that summer is here in Las Vegas,Nv. I had the Camshaft sensore replaced last year, it was the cause of me stalling out whenever I would get to running temp. A week ago I ran the A/C for about 10 minutes while idling then shut off. for about 10 minutes. Then the start up seemed rough and sounded/felt like it would stall. I revved the engine and sure enough it sounded brand new. And then today I started up just fine going through my neighborhood it didn't want to go past 20mph, sputtering and such about to stall, so I slammed the gas and it seemed to clear the problem for the day

Here is a couple ideas you can check into

Ive had a clogged converter do that before.its almost like running out of gas but you keep going
Your tps can also cause it to act this way my tps made mine spudder and stall it will rev up when sitting still but when you start off it didnt want to ecaler

Speedymcracer01 06-03-2013 02:56 AM

[QUOTE="Speedymcracer01;15512723"]

Here is a couple ideas you can check into

Ive had a clogged converter do that before.its almost like running out of gas but you keep going
Your tps can also cause it to act this way my tps made mine spudder and stall it will rev up when sitting still but when you start off it didnt want to accelerate the tranny didnt want to shift out either

Then the mass air flow will also do it but it doesnt normally clear up by revving the engine.actually revving the engine has not cleared it up with any of these problems usually if these sensors go bad it doesnt clear up.the idol will clear up but thats just until you try to go

jvillalp7 06-03-2013 03:00 AM

The throttle was the first thing I am going to check tomorrow. Cause it wont stall all the way or shut off " I ran the A/C for about 10 minutes while idling then shut off. for about 10 minutes" I shut it off myself cause I was running a little hot. But mine also does sputter some sometimes after regular freeway use then having to sit at a traffic light, kind of like the idle isn't high enough. And I have never had a problem sitting still and idling only that one time when I ran the a/c idling and started it back up. It is either after driving and then idling or starting up then getting going. ill update tomorrow when I check out the throttle.

jvillalp7 06-24-2013 04:59 AM

been away for awhile. Since I last posted its done it about 2 times just wont get up and then finally will, while parked it does have a knock the throttle seems fine im thinking transmission...

jvillalp7 06-24-2013 05:05 AM

Also figured out that my gas tank as well as my iol cap are spring loaded which both failed, and made remove them mechanically...seriously!

xXchevyXx 06-27-2013 06:04 AM

Got the same problem in my 2004 grand cherokee. Low end knock. Ill be rippin the oil pan out soon I'm gonna be doing an oil change too. I'm praying its just a loose bolt at the bottom of one of the pistons. Keep me posted, and ill return the favor.

jvillalp7 07-15-2013 12:18 AM

Havent figued out the problem yet. My Jeep will go for weeks without the problem then will happen for a short period of time and then disappear again

xXchevyXx 08-20-2013 05:48 AM

Engines still running starting to thinks its just a bad lifter.

noodles5124 08-20-2013 05:50 AM

Plugs and wire


The time now is 10:16 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.