98 Cherokee wont start - JeepForum.com
 
LinkBack Thread Tools
post #1 of 7 Old 01-08-2014, 06:05 PM Thread Starter
JerrodA
Registered User
 
Join Date: Jan 2014
Location: Shawnee
Posts: 4
98 Cherokee wont start

I have a 1998 Cherokee sport 4.0 straight 6. It wouldn't start the second morning of cold spell (started fine first morn). So I moved it into garage to warm it up. Been there for two days and still won't start. Power seems fine, turns over, not getting fuel and or spark. Tried starting fluid and even a little gas in intake and still nothing. Any thoughts?

JerrodA is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 01-08-2014, 11:48 PM
jnicewan
Registered User
1995 ZJ 
 
Join Date: Dec 2010
Location: Norman
Posts: 2,346
Did you verify no fuel or spark? As in no fuel pressure and no spark out of plug wires? If so check the relays, swap ASD relay with another relay in fuse box, like horn or A/C and see if that's it. If still no start you might test the crank sensor or replace it. The crank sensor is near the top LH/drivers of the trans bell housing where the trans mounts to engine. If you are not sure about fuel or spark, depress the throttle a little bit and try to start again, if that helps check the IAC valve for proper op, replace or clean for results. If you think it might be flooded then hold throttle to floor and attempt to start, release throttle if it starts.
jnicewan is offline  
post #3 of 7 Old 01-09-2014, 10:53 AM Thread Starter
JerrodA
Registered User
 
Join Date: Jan 2014
Location: Shawnee
Posts: 4
Thank you for response! Replaced crank sensor (that was not fun). Still same results. Unfortunately, like a dips#&t, I did not check and find out that I had no spark from plug wires before I did all that. So back to no spark, what should I check next?
JerrodA is offline  
post #4 of 7 Old 01-09-2014, 02:59 PM
jnicewan
Registered User
1995 ZJ 
 
Join Date: Dec 2010
Location: Norman
Posts: 2,346
Quote:
Originally Posted by JerrodA View Post
Thank you for response! Replaced crank sensor (that was not fun). Still same results. Unfortunately, like a dips#&t, I did not check and find out that I had no spark from plug wires before I did all that. So back to no spark, what should I check next?
Well, don't just check spark at plug wires, if you don't have spark there then check at coil too, that way you aren't missing something like a bad coil, coil wire, rotor etc. Is the problem still no fuel and spark, or are you not sure about fuel? Did you swap the ASD relay with another one yet, check all fuses, grounds, batt connections?
jnicewan is offline  
post #5 of 7 Old 01-09-2014, 03:09 PM Thread Starter
JerrodA
Registered User
 
Join Date: Jan 2014
Location: Shawnee
Posts: 4
I did swap the ASD relay, checked all fuses under hood and all the ones I thought it might be on interior fuse panel.
As far as fuel, I'm still not sure I'm getting any. As you can probably tell, I'm learning ad I go. I'll go check coil.
JerrodA is offline  
post #6 of 7 Old 01-13-2014, 07:17 PM
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
2010 JK Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 6,882
Unplug the VSS sensor on the side of the tranny. If it starts the VSS sensor is NG. It is on the same 8 volt circuit as the crank and cam sensor. When it shorts out the engine will turn over but will not start. AND it will not blow out any fuses.

Do you know what was good about the good old days? I wasn't good, And I wasn't old!

Senators and Congressman should wear uniforms like NASCAR drivers so we could identify their corporate sponsors....
laybackman is offline  
post #7 of 7 Old 01-14-2014, 08:40 AM Thread Starter
JerrodA
Registered User
 
Join Date: Jan 2014
Location: Shawnee
Posts: 4
I gave up and had it towed yesterday. Mechanic said it was a group if wires up under dash that short circuited ( I got that info second hand ). I will post actual diagnosis/ fix when I pick it up and talk to him. Thanks guys for the help.
JerrodA is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome