97 jeep tj 4.0lt - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 01-08-2013, 06:32 AM Thread Starter
JasonSnowKing
Registered User
1992 YJ Wrangler 
 
Join Date: Jan 2013
Location: Albany
Posts: 1
97 jeep tj 4.0lt

I have a 97 wrangler in-line 6 4.0l, around 1,100 RPMS it stumbles and chokes a little. I notice it more at higher speeds. We replaced the cap, rotor, distributor, plugs, wires were new at the time, so was the ignition coil. Idle air control valve, throttle position sensor, we replaced the injector for cylinder 6 and it improved. The codes that keep coming up are, PO300 and PO306. I brought it to a shop finally and they replaced the thermostat and gasket, radiator cap and the crank sensor.They also did a compression test, results were...
1-60 at first then he used marvel mystery oil and it went up to 130
2-130
3-130
4-145
5-130
6-130
All the symptoms are gone after he did the crank sensor, the jeep runs perfect, but the check engine light just came back on for the same 2 codes- p0300 p0306. I am out of ideas

JasonSnowKing is offline  
Reply

Tags
4.0 , codes

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome