97 Jeep Cherokee Country - Loud rattle from underneath the engine - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 09-11-2013, 10:54 AM Thread Starter
Drewcious
Registered User
 
Join Date: Sep 2013
Location: Albuquerque
Posts: 2
97 Jeep Cherokee Country - Loud rattle from underneath the engine

Hey All,

New to this forum. I was recently given a 97 Jeep Cherokee country from my dad. Jeep has close to 200,00 miles but overall has been kept in great condition with minor general repairs here and there. About a month ago i started hearing a low rattle from underneath the engine and since then it has gotten progressively worse when at a stop or idle. It sounds like rocks rattling around or like the engine is falling apart. First thought is the cat cause my dad said it did need to be replaced fairly soon according to his mechanic but the cat is pretty far back. This sound is right under the engine area. The exaust sounds normal but it seems like at idle it misfires a bit. What could this be?? Thanks!

Drewcious is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-11-2013, 12:51 PM
Terry777
Registered User
1997 XJ Cherokee 
 
Join Date: Oct 2010
Location: Coquitlam
Posts: 121
Crawl under and check if the heat shield plate around the cat is lose and rattling. If that`s it get some over sized ring clamps the ones with the screws and mate 2 together and put it around the cat and tighten it up. Worked great on my Acura and only cost me about $5.
Terry777 is offline  
post #3 of 4 Old 09-12-2013, 12:02 AM
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla
Posts: 1,961
What engine? Sounds like maybe the cats bad. Too much back pressure.
Does it do it cold or at temp?

http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline  
post #4 of 4 Old 09-17-2013, 02:34 PM Thread Starter
Drewcious
Registered User
 
Join Date: Sep 2013
Location: Albuquerque
Posts: 2
It does it at both but i think i determined the problem. The water pump. Ive noticed over the weekend my coolant res kept losing antifreeze and noticed the pully for the water pump jiggling. Took it to a mechanic earlier and hes pretty sure its the water pump too. I hope thats all it is but i do think i need to replace the cat next anyway.
Drewcious is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome