'96 cherokee sport Clutch Issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > '96 cherokee sport Clutch Issue

Building a Bumper?Ruffstuff Axle Simple Swap Kit!~Artec JK 1 TON SWAP~

Reply
Unread 10-24-2013, 02:46 PM   #1
blavek
Registered User
1996 XJ Cherokee 
 
Join Date: May 2013
Posts: 5
'96 cherokee sport Clutch Issue

Hey guys, I have a '96 cherokee sport 4.0 with the inline 6. I have about 140k miles on the car. The issue I am having is that there is a lot of play in my clutch pedal and when I depress the clutch pedal all the way to the floor my clutch is still partially engaged. Its not engaged enough to stall the vehicle with the brakes depressed but it is engaged enough that the car will idle forward or attempt to move upon start up. I intend on taking care of this issue this weekend and I want to know what my most likely culprits are.

I am thinking Slave Cylinder
I hope its not the throwout bearing.

But is there anything else that could be my problem?
My clutch was replaced at about 80K miles if that helps.

Thanks for you consideration


Last edited by blavek; 10-24-2013 at 02:59 PM..
blavek is offline   Reply With Quote
Unread 10-27-2013, 03:03 PM   #2
blavek
Registered User
1996 XJ Cherokee 
 
Join Date: May 2013
Posts: 5
It looks like my issue was the slvae cylinder. Its a shame though due to poor bleeding instructions I managed to snap the linkage to my master cylinder and had to replace that as well. But it took all the play out of my clutch and the vehicle shifts very nicely now.
blavek is offline   Reply With Quote
Unread 02-14-2014, 02:57 AM   #3
aggiexj11
Registered User
 
Join Date: Feb 2014
Posts: 1
I need some help. I have a 95 cherokee I was driving home and mu gears wouldn't go in and my pedal got really loose. I got home and noticed it leaked all my clutch fluid. I couldn't figure out where it was leaking from. It was not my line or slave cylinder. I replaced my master cylinder just I case but now I can get my pedal to get stiff like it should be. It is really loose and no preasure even after bleeding the system. What can it be? FYI if I left the pedal pressed before I changed the master cylinder it would leak faster and I noticed that somehow some of the fluid was leaking from In between the transmission and motor. Does that sound right? I'm Carless now so I need to fix it ASAP
aggiexj11 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.