95 ZJ Transmission Issues! HELP!!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > 95 ZJ Transmission Issues! HELP!!!

NEW JK WRANGLER GRAB BARS NOW at ROCKRIDGE4WDROCKRIDGE4WD Introduces a NEW Jeep Wrangler JK *led* tail Ruffstuff XJ Unirail Channel Reinforcement....

Reply
Unread 10-30-2012, 06:04 PM   #1
zjmike92
Registered User
 
Join Date: Oct 2012
Location: Greenville, NC
Posts: 2
95 ZJ Transmission Issues! HELP!!!

Hey guys this is my first time posting on here so I hope I did everything ok.

I have a 95 Grand Cherokee with the 4.0 and 42le transmission. I recently just got the vehicle and it runs and drives great, other than not going into overdrive. But I think that is because of the ON/OFF button on the dash. It has worked before.
Most of the time when I drive it, starting from a stand still in D, it has no power and feels like it doesn't shift at all, nor go into overdrive. Occasionally the transmission will go through all the gears and overdrive just like it is meant to be. I usually just drop it into M2 to have better pickup, M1 is like M2 in my jeep. But just last night it wont back up. I can put it in reverse, the reverse lights come on, but its like it strains to back up, just sits there and revs to 2000 rpms. all forward gears have worked fine today, as long as i **** down to M2 and then to D. This is my first jeep so Please help me figure out whats wrong and what I can do to figure it out. Thanks!!

zjmike92 is offline   Reply With Quote Quick reply to this message
Unread 10-30-2012, 07:34 PM   #2
TheFryer
Registered User
1996 XJ Cherokee 
 
Join Date: Oct 2012
Location: gainesville, Georgia
Posts: 28
your could try replacing the trans filter and the fluid. it should look red on the stick, not brown or black. mine is having issues as well with lockup. also had some shifting issues that have been going away sense i did a filter and fluid change.
TheFryer is offline   Reply With Quote Quick reply to this message
Unread 10-31-2012, 11:16 AM   #3
syrus64209
Registered User
1997 ZJ 
 
Join Date: Aug 2011
Location: lansing, mi
Posts: 90
While u are in there doing the trans filter change out the governor pressure solenoid they are fairly cheap and tend to go bad causing it to not shift I had to replace mine last spring because it wouldn't shift into 3rd I believe until I let of the gas and go back on it. Not exactly what u got going on but while ur there it wouldn't hurt.
__________________
[COLOR="Black"][CENTER][SIZE="4"][FONT="Showcard Gothic"][COLOR="Black"][URL="http://groups.jeepforum.com/built-not-bought/"][COLOR="Black"]Built Not Bought #553[/COLOR][/URL][/FONT][/SIZE][/COLOR][/CENTER][/COLOR]
syrus64209 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.