91 2.5l yj starting/running issues - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 07-14-2013, 08:44 AM Thread Starter
91blackyj
Registered User
1991 YJ Wrangler 
 
Join Date: Sep 2012
Location: uxbridge
Posts: 82
91 2.5l yj starting/running issues

Ok I have a 91 yj. Since I've had it its always had a high idle. 1100 up to 1800 sometimes a lil more than 2k. And ran a little rough at times.

Ok omw to my house after a 300mile maybe more drive up to mass. I was omw home and it started miss firing and then completely shut off the engine. Coasted to side of road and tried starting it. Nothing. 5 cranks later I called triple a. Then tries again starting. 5 mins later triple a came. Got it dropped off home and then started it up. It ran but missed a little. So u would assume fuel pump. Got a whole drop in unit and put it in. Connected everything and started it up. It started up fine. Bolted it back up and drove it around the neighborhood. Still missed. So I was like ok that's not good. Then tried driving it to my gf's and down the street it started missing pretty badly. Then died. Started it up and wouldn't start. Rolled back and rolled down the street. Started it. Nothing. Then tried pop starting it. It started. Then missed and died. Pop started it again and started but ran ****ty. I then parked it and it idled fine. Then missed reved it. It was fine. Then missed a lot then I shut it off. Any ideas?

Also all spark plugs are recently new same with all the wires, and rotor cap. Have the tip at the apartment but haven't put it on. I also replaced the coil. New battery, new fuel filter and fuel sending unit. Now when I installed the new sending unit. It didn't fit down the whole way so I tried figuring out why and decided to just screw it in and the plastic tank will be pulled up a little. Also got it from crown and they said both 2.5l and 4.0l have same fuel pump. Anyone have any ideas. Need to get back to maryland asap.

91blackyj is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-14-2013, 01:32 PM Thread Starter
91blackyj
Registered User
1991 YJ Wrangler 
 
Join Date: Sep 2012
Location: uxbridge
Posts: 82
I also have a code 24 the throttle position sensor. The other 3 codes are normal I've been told
91blackyj is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome