91 2.5L won't start intermittently... - JeepForum.com

LinkBack Thread Tools
post #1 of 1 Old 03-20-2014, 06:04 PM Thread Starter
Registered User
1993 YJ Wrangler 
Join Date: Aug 2011
Location: Black Hills
Posts: 687
91 2.5L won't start intermittently...

I think Jeep used the "iron duke(y)" in some of their models. Unfortunately, this one is in a Suck-10 Chevy.

Some mornings after it has rained or with a high dew point, it won't start. There is no primary or secondary spark. I have replaced the coil, cap & rotor and plugs &wires. This has been going on for years now and I can't track down the cause. I've tried sealing the cap with RTV, though there is no corrosion inside the distributor to indicate moisture being the problem. I relocated the coil and have checked the wires to it. I don't want to sink a ton of cash into it because it's not a primary driver and I want it to DIE so I can swap a 350.

Any ideas on this?

UZI4U is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome