4.0L sounds like tea kettle while accelerating - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > 4.0L sounds like tea kettle while accelerating

Poison spyder items @ oconee off road 706 534 9955Jeep Wrangler Framless, Bowless, Trektops 92-95 YJ, 97-06 TJ 5.25" Speaker Adapters - NalinMFG

Reply
Unread 04-11-2009, 11:02 AM   #1
RockSalt
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2009
Posts: 46
4.0L sounds like tea kettle while accelerating

I've searched the forum as best I can but I just cant seem to find a thread with the same problem as mine just allot that are very similar. When I accelerate I get the sound of a tea kettle/(the angry sparrow sound others seem to have experienced)/turbo charger type sound/whistle. It only occurs some of the time (about 80%) and only while accelerating, it goes away as soon as I let off the gas. The sound sometimes begins in 1st gear but not always, usually loudest in 2nd and 3rd and almost disappears in 4th and is gone in 5th. Also tends to be lessened while driving in rainy weather? but can't confirm if the rain is just covering up the sound. The sound used to only last for a short while after the engine was started but now it last longer and is more frequent. almost positive sound is coming from engine and not drive train but because im working by my self and I have to be accelerating its hard to tell. Please help, thank you in advance.


Im greatly right now

RockSalt is offline   Reply With Quote
Unread 04-11-2009, 11:47 AM   #2
DC4W-93XJ
Registered User
1990 XJ Cherokee 
 
Join Date: Oct 2008
Location: Grand Junction, Crawlorado
Posts: 579
sounds like an alternator whine to me, when you kick the RPMs up the alternator puts out more amps which can be heard through the stereo.. nothing to worrie about, if it bugs you that much you can get noise deadeners or whatever they're called that go on the power wires to your stereo..
do you have a cold air intake or a free flowing intake on it?? that could whistle too..
__________________
THIS AIN'T YOUR MAMA'S STATION WAGON!!
Built Jeep Tough With Chevy Stuff
"Tater 2" '91 2 door XJ chopped and bobbed, 4.0, AW4, dana 300, GM 60/70HD, 40" IROKs on H1s
SEE THE BUILD HERE
DC4W-93XJ is offline   Reply With Quote
Unread 04-11-2009, 01:30 PM   #3
RockSalt
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2009
Posts: 46
I doubt that it is the alternator affecting the stereo as my system is hard wired to the battery and if disconnected the problem persists. As for the Intake, no modifications have been done around the time when this first occurred. Also, I've noticed a decrease in fuel millage and power.
RockSalt is offline   Reply With Quote
Unread 04-11-2009, 05:44 PM   #4
RockSalt
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2009
Posts: 46
update:

Cleaned engine with Gunk engine cleaner, sound disappeared for a little while but came back and now I find that it may be leaking oil from valve cover. It's been going through allot of oil lately and engine pressure has been down but then one morning puddle of oil on floor under jeep, after inspection and re filling of oil yet again engine pressure back to normal. maby im just being over cautious of my baby but at least the sound is back to only being for a short period after I start driving and the oil pressure is back to normal.
RockSalt is offline   Reply With Quote
Unread 04-11-2009, 07:42 PM   #5
1998JEEPZJ
Registered User
 
Join Date: Apr 2009
Location: Cumberland RI
Posts: 76
I have an issue like this in my 98 ZJ, mine sounds like its coming from the tranny, I don't seem to have any drivablity issues with it so im not really worried, yet at least. Im still getting a wopping 18 miles per gallon
1998JEEPZJ is offline   Reply With Quote
Unread 04-11-2009, 08:30 PM   #6
RockSalt
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2009
Posts: 46
I thought mine was Tranny or T-case at first but it still could be. . . . any suggestions ?
RockSalt is offline   Reply With Quote
Unread 04-12-2009, 05:17 AM   #7
RockSalt
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2009
Posts: 46
I confirmed the engine is leaking oil (allot of oil) from the front left of the valve cover (looking at the engine) could this be causing the noise ?
RockSalt is offline   Reply With Quote
Unread 04-12-2009, 07:43 AM   #8
1998JEEPZJ
Registered User
 
Join Date: Apr 2009
Location: Cumberland RI
Posts: 76
Quote:
Originally Posted by RockSalt View Post
I confirmed the engine is leaking oil (allot of oil) from the front left of the valve cover (looking at the engine) could this be causing the noise ?
I doubt its the oil leak making this noise.
1998JEEPZJ is offline   Reply With Quote
Unread 04-12-2009, 07:59 AM   #9
RockSalt
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2009
Posts: 46
I realize how that sounds now, I've been up all night on grave yard shift, minds not working so well. but the fact that the oil got very low well below add could have something to do with this. Also I know my valves are going bad as i got a noticeable knock as well as this "click click" sound that sound like the auto sparker thing on a gas stove
RockSalt is offline   Reply With Quote
Unread 06-01-2009, 04:26 PM   #10
RockSalt
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2009
Posts: 46
just a note that after replacing all the seals the sound is gone?
RockSalt is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.