304 V8 Carb problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > 304 V8 Carb problems

Huge Soft top SaleRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits BLACK FRIDAY SPECIALS!! You asked, we deliver!

Reply
Unread 09-26-2012, 10:52 AM   #1
texasjeepz
Registered User
1981 CJ7 
 
Join Date: Jun 2012
Location: weatherford, tx
Posts: 5
304 V8 Carb problems

Hey guys can anyone help me I have the motorcraft 2100 carburetor on a 304 81 cj7. I replaced the small rubber piece in the inside of the front part of the carb (mine had a leak) however its not running good, I will finally get it started then as soon as I press the gas pedal it dies. It does need an oil change and new sparks but I don't think thats main problem. I have a holley electric fuel pump that is pumping the gas fine. and also bought a new fuel filter. Any ideas??? please help, i am not a mechanic but want to do myself to save $$. . thanks!! I'm new to jeep forum I hope I did this right... please reply or send a message back. need all the help i can get!

texasjeepz is offline   Reply With Quote Quick reply to this message
Unread 09-27-2012, 07:52 AM   #2
90DesertTanYJ
Registered User
1990 YJ Wrangler 
 
Join Date: Jun 2012
Location: Jacksonville, FL
Posts: 750
I would say if it didnt have the stumble before you installed the new rubber piece that you need to go over your work and see what you did. I am not sure what rubber piece you are talking about but if it has to do with the needle valve, it may not be allowing fuel into the bowl fast enough or you messed with the float and too much fuel is coming in and flooding. It will affect your drivablity either way. If you replaced the power valve, something is wrong there as that gives the engine the extra fuel needed to accelerate.

Like I said, check your work for proper operation.
90DesertTanYJ is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.