3 speed tranny, please help! - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > 3 speed tranny, please help!

RIGID LED Light Blowout Sale - All Sizes, All Series, all Truc-Lite LED Headlights! OCONEE OFF-ROAD 706-534-9955Jeep Wrangler Bushwacker Flat Fender Flare Sale at Baselin

Reply
Unread 05-22-2012, 12:07 PM   #16
rjbruzan
Moderator
2004 TJ Wrangler 
 
Join Date: May 2008
Location: Lake in the Hills, illinois
Posts: 2,077
I had a Ford MotorHome with a 460 and C-6 trans. Coming back from Florida it started leaking out of the bellhousing a quart every 100 miles. So I kept it full and when I got home pulled it and installed a new front seal. Less than 10 miles later its leakin real good again. So I put in a second seal. Still leakin alot. So my buddy says try some DYE in the trans. So I cleaned it up real good and put in a couple of ounces of dye. A quick 10 minute ride and the dye showed up under ultra-violent light. I pulled the trans and found one of the welded nuts on the torque converter had a minute crack that only showed up under pressure. If it had been a beater I would have cleaned it and brazed all 4 of the nuts on to seal them but it was a good vehicle so I bought a new one.
I got real good at pulling that trans on my angled,gravel drive on a sheet of plywood.
Ron

rjbruzan is offline   Reply With Quote Quick reply to this message
Unread 05-22-2012, 12:49 PM   #17
austonreeves
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2010
Location: Prattville, Alabama
Posts: 1,556
I went about 5 miles and I'll be damned if it didn't act up again! Started slipping, leaking and now it wot even engage into a gear..... You have no idea how mad I am! When I put it in neutral.. It makes a whinning noise which makes me think it's the pump but i just had this thing rebuilt and I called the people who rebuilt it but since I took it out and put it back in, it apparently avoided the warrenty

Sent from my
austonreeves is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.