3.7L horrible gas milage - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > 3.7L horrible gas milage

Labor day sale @ rockridge 4wd! 8/29-9/1 site wide..promo Rough Country Deals at JeepHut.comShocktober is here! Get new shocks for your Jeep!!!!

Reply
Unread 08-29-2011, 07:24 AM   #1
ifelovr
Registered User
2002 KJ Liberty 
 
Join Date: Aug 2011
Location: Jacksonville, Florida
Posts: 17
3.7L horrible gas milage

Yep, this one has me stumped. I have a '02 Liberty with a 3.7L V6. I am currently getting 11 MPG and this is what I have changed so far; Plugs (burning clean just wore out), Air Filter very dirty, Oil, Radiator Fluid (drain & flushed), trans fluid & filter, rearend fluid and brakes (front & back).
I'm not getting any codes which rules out O2 sensor. All I can think is a vacuum leak that I cannot find. Is there anything I may be missing? I'd appreciate any help. My appologies if I started this thread in the wrong place.


Last edited by ifelovr; 08-29-2011 at 07:43 AM..
ifelovr is offline   Reply With Quote
Unread 04-14-2012, 10:17 PM   #2
JCemenski
Registered User
 
Join Date: Mar 2012
Posts: 21
Check your vac lines. I'm having same problem and I noticed a lot of mine are dry rot and mine is an 02 with 143k.
JCemenski is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.