258 carb issues - JeepForum.com

LinkBack Thread Tools
post #1 of 1 Old 04-10-2013, 03:15 PM Thread Starter
Registered User
1985 CJ7 
Join Date: Feb 2013
Location: Bristol
Posts: 8
258 carb issues

Im working on a 85 Cj7 with the 258 and the stock carb.

the choke is missing, im operating it by hand right now
I can only get the thing to fire if i prime the carb with fuel, after it starts it runs fine...
I have verified the fuel pump is working, what would cause this?

F4u5T is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome