2006 Commander feels like its pulling - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > 2006 Commander feels like its pulling

Eliminate Hood Flutter!!!Steinjäger photo contest!TJ 5.25" Speaker Adapters - NalinMFG

Reply
Unread 07-18-2013, 12:34 AM   #1
d21
Registered User
 
Join Date: Jul 2013
Posts: 5
2006 Commander feels like its pulling

Hey guys I need some help..I have an 06 Commander that at time as I take off it feels like its pulling. Its very noticeable does it once in a while. Have any ideas on what it is...Thanks

d21 is offline   Reply With Quote
Unread 07-19-2013, 07:51 AM   #2
JeepCares
Registered User
 
Join Date: Jan 2012
Location: MOPAR World Headquarters, Chrysler Group LLC
Posts: 2,436
Please be more specific. Which powertrain? Any pattern to the "once in awhile?" Taking off from a cold start, taking off from a stop light? Pulling as in not accelerating quickly or pulling to one side?
__________________
Lee
U.S. Top Care
Chrysler Group LLC
JeepCares is online now   Reply With Quote
Unread 07-19-2013, 11:34 AM   #3
d21
Registered User
 
Join Date: Jul 2013
Posts: 5
Its a 3.7L. It happens after a cold start and taking of from a red light. Ive also noticed it as im driving I lower my speed then between 45m to 65mph I feel it. It feels like its losing lower, jerking, back and forth. . Hill or straight road it does it.
d21 is offline   Reply With Quote
Unread 08-01-2013, 10:27 AM   #4
rstlshumpert
Registered User
2007 XK Commander 
 
Join Date: Aug 2013
Location: Pensacola, FL
Posts: 2
I have the same issue. Did you get an answer for this?
rstlshumpert is offline   Reply With Quote
Unread 08-02-2013, 05:19 AM   #5
d21
Registered User
 
Join Date: Jul 2013
Posts: 5
No I never got an answer.
d21 is offline   Reply With Quote
Unread 08-02-2013, 11:54 AM   #6
caiha
Registered User
 
Join Date: May 2012
Posts: 94
Does it constantly pull or just on hard take offs? Is it AWD all time if it is it could be torque steer but that's usually found only in FWD vehicles
caiha is offline   Reply With Quote
Unread 08-02-2013, 11:55 AM   #7
caiha
Registered User
 
Join Date: May 2012
Posts: 94
You might have the front end checked for worn parts. Worn parts such as bushings in control arms can cause this.
caiha is offline   Reply With Quote
Unread 08-02-2013, 12:07 PM   #8
d21
Registered User
 
Join Date: Jul 2013
Posts: 5
Its an AWD and it happens when I take off and when im at spends between 45 -65. I will look into what you mentioned appreciate it.
d21 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.