2004 Grand cherokee 4.7 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > 2004 Grand cherokee 4.7

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineThe Solution to Radius Arm Bind - Meet Lock-N-LoadFS: Jeep Fog Light LED Bulbs! Several Brightness Options!

Reply
Unread 05-02-2014, 07:13 PM   #1
eddiepunme
Registered User
2004 WJ 
 
Join Date: Apr 2014
Location: Cleveland, TN
Posts: 2
2004 Grand cherokee 4.7

I recently got this vehicle with 78k on it and already had a P1281 code. changed the thermostat ( they had put a therm housing in after punching the thermostat out to keep it cooling ) and now I've noticed another problem. when I first got it I noticed a slow start. it'd turn over twice and then start. today I went to start it and it wouldn't at first. had to find the sweet spot on the ignition and keep trying the key until it started. now it's hesitating when I try and start it. autozone tests say battery good and alternator ( voltage regulator ) is bad. I go inside and their computer says it has a external regulate. which i'm finding is on the PCM. alternator looks new .spoke with people and they stated that it isn't the starter due to no clicking or grinding. I don't have the funds for the process of elimination. some say plugs some say alternator( even though interior lights don't dim and gauge stays stable right around the 14. )some say starter and some batter. What experience does anyone have in this?


Last edited by eddiepunme; 05-02-2014 at 07:34 PM..
eddiepunme is offline   Reply With Quote Quick reply to this message
Unread 05-06-2014, 03:58 PM   #2
akoutdoors1
Registered User
2000 WJ 
 
Join Date: Apr 2014
Location: Buckeye, AZ
Posts: 406
How is your coolant level?
akoutdoors1 is offline   Reply With Quote Quick reply to this message
Unread 05-07-2014, 07:04 PM   #3
eddiepunme
Registered User
2004 WJ 
 
Join Date: Apr 2014
Location: Cleveland, TN
Posts: 2
Coolant level is fine. Its not done it again but i'm iffy about taking trips further than 30 mins away
eddiepunme is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.