2003 WJ 4.0 CEL code P0206 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > 2003 WJ 4.0 CEL code P0206

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 08-12-2012, 11:25 PM   #1
pushinacoach
Registered User
 
Join Date: Dec 2011
Location: On The Road, USA
Posts: 12
2003 WJ 4.0 CEL code P0206

Need some Jeep wisdom here. Several days ago the engine began to run roughly and the check engine light came on. I have an Autel Diagnostic Tool and pulled a P0206 - Fuel Injector #6 cyl code. I replaced all the injectors with 4 hole Bosch injectors and replaced all the spark plugs. Now the issue seems to be intermittent rather than constant. It will idle smoothly and run great and then without warning run rough and "miss". I get the same code when I scan the system.
BTW - I had a similar issue about 8 months ago and changed the coil pack and plugs and released the pressure in the fuel rail. No more problems at all until last week. Nothing has changed with the JGC. Stumped. Any thoughts? Thanks.

pushinacoach is offline   Reply With Quote
Unread 08-13-2012, 12:25 AM   #2
jnicewan
Registered User
1995 ZJ 
 
Join Date: Dec 2010
Location: Norman, OK
Posts: 2,006
Check the connector at cyl #6 injector. I had one in the past that had a loose pin in the connector. Also look at the wiring real good and make sure its not rubbing somewhere and check to see if the connection at the PCM is good too.
jnicewan is offline   Reply With Quote
Unread 09-09-2012, 06:30 AM   #3
pushinacoach
Registered User
 
Join Date: Dec 2011
Location: On The Road, USA
Posts: 12
Well, finally got the problem solved. It was the wire harness that runs behind the head to the fuel rail. It had chaffed on the head bolt and 4 wires were exposed and shorting. Wires spliced and harness repaired and no more problems. Thanks for the help.
pushinacoach is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.