2002 overland transmission - JeepForum.com

LinkBack Thread Tools
post #1 of 3 Old 01-31-2013, 01:43 PM Thread Starter
Registered User
Join Date: Jan 2012
Location: Innisfil
Posts: 10
2002 overland transmission

Was wondering if anyone could help me on this one. When I put my jeep into drive sometimes it jerks really bad. I have taken it into transmission shops and there telling me nothin is wrong. Could it be a sensor?

Mikey_Overland is offline  
Sponsored Links
post #2 of 3 Old 02-03-2013, 10:08 AM
Registered User
1989 YJ Wrangler 
Join Date: Nov 2010
Location: Sin City
Posts: 2,881
Usually when that happens it is a lck of pump pressure. You get a slight delay and then BAM!!! So depending on your miles a fluid and filter change or go to the shop and have it flushed. On newer like yours it will throw a code when the sensors are baad you should have a low and high speed sensoe along with a vehicle speed sensor (speedo only). If you can't do it your self take it to the shop.

89YJ 2.5L TBI, AX-5, NP231 SYE, Ford 8.8, Yukon Grizzly, Tom Woods Shaft, 33" BFG T/As, 4" lift, Warn VR10000s.

AF Jeep Club Tail #184
jokerchief462 is offline  
post #3 of 3 Old 02-03-2013, 10:23 AM Thread Starter
Registered User
Join Date: Jan 2012
Location: Innisfil
Posts: 10
Thanks for the advice dude.
Mikey_Overland is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome