2000 wrangle sport 4.0 stalls randomly - JeepForum.com
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > 2000 wrangle sport 4.0 stalls randomly

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! 1999-2004 Jeep Grand Cherokee Limited Headlight Pair1999-2004 Jeep Grand Cherokee Laredo Headlight Pair for Mo

Unread 05-23-2012, 07:07 PM   #1
Registered User
Join Date: May 2012
Posts: 1
2000 wrangle sport 4.0 stalls randomly

Hi, I'm new to the forum and love my jeep. I have a 2000 wrangle sport 4.0 auto and it has been stalling randomly, while stopped or driving. I would really appreciate it if anyone can recommend the best jeep mechanic in south eastern Michigan. I have had it looked at by a few local mechanics and a friend has had Chrysler engineers give crappy advice. It starts right back up and is not giving any codes. Asd valve opening when not supposed to, crank sensor and computer brain are new, no help. Thanks in advance for any help!

h10weaver is offline   Reply With Quote Quick reply to this message
Unread 05-23-2012, 07:54 PM   #2
Registered User
2005 TJ Wrangler 
Join Date: Apr 2012
Location: Williamson, WV
Posts: 89
My 05 would do this occassionally. It was a 2.4 but it was the battery. MY negative post (i believe) had corroded really badly, enough that it ate through the post some. Even after I cleaned it it would still happen. Once or twice while driving, mostly when comming to a stop. It didn't happen enough that I would call it a regular thing, but it was enough to keep my mind on it. I didn't notice the terminal being eaten up till I went to replace the battery and then a couple weeks later wiring up a winch I broke the terminal. It had been eaten a little bit as well from the corrosion I suppose. If you've ever had any problems with that I'd check out your battery first, clean up the terminaly and posts really good and smear a little di-electric grease on it. i haven't had a problem since, granted it's only been about a month but no corrosion and no more stalls.
Cvarney is offline   Reply With Quote Quick reply to this message

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools

Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.